Jump to content


Photo
- - - - -

image on photo gallery "blog post" appears in header area


  • Please log in to reply
10 replies to this topic

#1 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 11 July 2012 - 05:06 PM

Hi there,
I added some photos to a page in a simple standard WP gallery and when I view the page here:

Please Login or Register to see this Hidden Content


and then click on the actual photos it takes me to another page:

Please Login or Register to see this Hidden Content

that is apparently the "blog post" template and the image is repeated up on top above the header area for some reason. I can't find this in any of the template areas to remove it.
Can someone help me? I'm not sure why it defaults to a blog post template either.
Thanks!!

#2 batman

batman

    Bat Learning

  • Members

  • 2115 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 11 July 2012 - 05:48 PM

Hi
When I want to go another page clicking a image I use in the edit visual mode
Click image
Go to
??insert/edit link (Alt+shift+A)??
Posted Image
and insert the URL

If you don??t go to any place verify your attachment with this method to see if it works.

#3 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 11 July 2012 - 05:55 PM

@batman, I don't want to go any page in particular, just a page that does not have an image on top of the header. I am not sure I should I have to edit every link to make sure it doesn't take me to this default blog post page...and why can't I change the default blog post page to remove that from the top? It does not appear in my meta settings...

#4 batman

batman

    Bat Learning

  • Members

  • 2115 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 11 July 2012 - 05:58 PM

Now I understand you, sorry. I don??t know what happened, sorry again.

#5 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 12 July 2012 - 02:17 AM

When setting up your WP image gallery, what links are input for the images in the gallery settings?

#6 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 12 July 2012 - 01:41 PM

@catrina, I created the gallery by dragging and dropping three images into the uploader. It creates the links automatically. Upon checking, for example, the first photo link defaults to:

Please Login or Register to see this Hidden Content

Does this help in the "investigation"? :)

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 12 July 2012 - 02:11 PM

Yes, it does. The thumbnail link should actually lead to that direct URL instead. Hm.

#8 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 12 July 2012 - 02:22 PM

@catrina, indeed, it should. i don't now why it's going to this weird blog post page instead. did i do something wrong?

#9 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 12 July 2012 - 03:01 PM

@catrina, is there something I can do to fix this without doing it manually each time for every photo? My client is going to be updating the site and I can't have her do that every time.

#10 bxbmedia

bxbmedia

    Advanced Member

  • Members

  • 79 posts
  • LocationAnn Arbor, MI

Posted 13 July 2012 - 01:37 AM

@Tan,

See the codex for the

Please Login or Register to see this Hidden Content

.

The default link for the image is the attachment's permalink which is what you're seeing.

You can change this to link to the file itself by using the link attribute like so:

Please Login or Register to see this Hidden Content


A nice addition to that would be to just install a lightbox plugin like

Please Login or Register to see this Hidden Content

to display the larger images without loading another page :)

#11 tandan

tandan

    Super Member

  • Members


  • 152 posts
  • LocationNew York
  • Country: Country Flag

Posted 13 July 2012 - 03:09 AM

@bxbmedia thanks so much! that worked like a charm. :)