Archived

This topic is now archived and is closed to further replies.

  • 0

Feature overlay after upgrade - Bug??

Question

Posted · Report post

Hi all, It seems that the feature overlay settings no longer work properly after upgrading to 2.2.2. The only one that shows correctly is 'Black text - no feature background - no overlay'. The others all include the overlay even when they shouldn't.... Can anyone confirm this and perhaps help get it fixed?? Thanks, Glyn

Share this post


Link to post
Share on other sites

24 answers to this question

Posted · Report post

Glynt, just to make sure... do you have a cache plugin working? If so, did you clear the cache?

Share this post


Link to post
Share on other sites

Posted · Report post

Glyn, I don't know what's taking so long, so I'll submit a bug report for you.

Share this post


Link to post
Share on other sites

Posted · Report post

HI Danny, Thanks for your reply. I am also using 2.2.5 and I have created a new feature as you suggested. I used the 'White text - Dark feature background - no overlay', but there is still an overlay... Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Batman, Rangelone, Many thanks for your replies... Batman, yes, with 'White text - dark feature background - No Overlay' the overlay still appears. I have tried all the options and the only one that seems to work correctly is 'Black text - No feature background - No Overlay'. You are right that I could probably make it how I want it with CSS but I'd much rather just select an option!! And I think that if it is a bug the nice people at Pagelines will be wanting to fix it.... Rangelone, tried clearing the cache but no luck I'm afraid... Many thanks, Glyn

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not sure if it is a bug, but if so, a developer will need to take a look at it. For the time being, do you want a CSS solution?

Share this post


Link to post
Share on other sites

Posted · Report post

Can you try clearing your browser cache and checking your site to see if the overlay is still there?

Share this post


Link to post
Share on other sites

Posted · Report post

Glyn, the developers are aware of it, so we'll have to wait for their solution.

Share this post


Link to post
Share on other sites

Posted · Report post

OK, thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Glyn, I have just added a new feature slider and gone trough all the text/overlay settings and they all appeared to be working as intended. Can you try creating a new slide and try for yourself please. I was using PageLines Framework 2.2.5.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Please try go to Features > edit > Features Option > Feature position choose one. Then you can edit by CSS rules as you like.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Batman, Do you mean 'feature text position'? This works fine to change the positions of the text... but the selector below no longer works which changes the style of the text and overlay....

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Catrina, Yes please, a CSS solution would be good for now... the code that batman suggested works but I need to target specific feature slides or specific pages... any help with that would be most appreciated... Many thanks, Glyn

Share this post


Link to post
Share on other sites

Posted · Report post

@glynt The "Feature Design Style" works fine too in my test forum with Pagelines Framework 2.2.2 I can not help, wait from some of the staff, I??m a newbie try learn helping.

Share this post


Link to post
Share on other sites

Posted · Report post

Glyn, I tried it myself on my own site and had the same issue. Apparently, some of the CSS code for the feature slider seems to get caught somewhere, somehow and does not make its way into the site. Do you have cache or CDN enabled? If so, clear it, deactivate it, then go to Store > Sections and deactivate Features. The Features section will go to the bottom of the list. Go there and reactivate it. Then view the site. Turn on the cache or CDN again and clear once more. Refresh your browser too, for good measure. Let me know if this works.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Rangelone, Didn't work I'm afraid... but it was worth a try, thanks for the suggestion... Cheers, Glyn

Share this post


Link to post
Share on other sites

Posted · Report post

HI Catrina, Still there after cache cleared I'm afraid.... Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Glyn, I apologise but I am not quite sure where you're referring to when you say overlay?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Catrina, No, can you suggest any? I would need to target specific features... Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

To target the background for the feature overlay, you can use Firebug or Chrome development tools. To learn how to use Firebug for CSS customizations, please read and follow these instructions: http://www.pagelines.com/wiki/Custom_CSS. The CSS selector is used to select the page element you want to change (in this case, the page element you want to change is the feature overlay). For help with the background color attribute (which needs to be tweaked to make the adjustment on your feature overly), please see this: http://www.w3schools.com/cssref/pr_background-color.asp

Share this post


Link to post
Share on other sites

Posted · Report post

Hm, I think there is a way to hide an overlay background with a CSS workaround. Have you tried any yet?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Danny, 'Overlay' is the term used in the feature set up section. In the 'feature design style' section there are two settings that can be changed. The first is titled 'Feature text position' and the second is titled 'Feature design style'. 'Feature design style' has four select-able options to choose from: 'White text - Dark feature background - Transparent text overlay (default) 'Black text - Light feature background with border - No Overlay' 'White text - dark feature background - No Overlay' 'Black text - No feature background - No Overlay' The 'overlay' is the semi-transparent part of the feature that is down the left or right hand side. After the latest upgrade the options above which say 'no overlay' aren't working except for the last one. The others all still have the overlay.... Cheers, Glyn

Share this post


Link to post
Share on other sites

Posted · Report post

Hy glynt I load the image at Full Size - Feature Background Image and select Feature Text Position 'Text On Left' Feature Design Style 'White text - dark feature background - No Overlay' You can see the image. Captura%2520de%2520pantalla%25202012-07-11%2520a%2520las%252014.03.02.jpg Is this that you say? You are right the semi-transparent appears

Share this post


Link to post
Share on other sites

Posted · Report post

You can try add PageLines > Site Options > Custom Code > CSS Rules #feature_slider .fcontent {background: none;} I suppose that disappear.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi all, This still seems to be not working properly even after recent upgrades.... any chance of getting is sorted?? Thanks

Share this post


Link to post
Share on other sites