Jump to content


Photo

Upgraded to WP 3.4.1 and encountered multitude of errors


  • Please log in to reply
5 replies to this topic

#1 eschenck

eschenck

    Member

  • Members
  • PipPip
  • 27 posts

Posted 10 July 2012 - 08:54 PM

Hello! I upgraded recently to WP 3.4.1 and my site went haywire with errors scrolling down the top. I've explore the forum and couldn't find an answer - could someone please point me in the right direction? I hope that it's just a matter of replacing a file. I already tried deleting Platform Pro and Platform Pro Base and re-installing. Didn't help unfortunately. Many thanks in advance.

#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 10 July 2012 - 10:03 PM

Turn off WP_DEBUG in wp-config.php, or if thats already off, ask your host to set display_errors to Off. Should always bee off on a production server.

#3 eschenck

eschenck

    Member

  • Members
  • PipPip
  • 27 posts

Posted 17 July 2012 - 05:05 PM

OK, the display_errors are set to off. I contacted my host, and they informed me that it was a genuine problem with the theme. Has Pagelines been able to permanently fix this? If so, what do I need to do? My site is currently in Twenty Eleven due to the crisis. Thanks.

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 July 2012 - 05:33 PM

can we at least see a screenshot of the errors?

#5 eschenck

eschenck

    Member

  • Members
  • PipPip
  • 27 posts

Posted 18 July 2012 - 01:58 PM

Here are two screenshots because you have to scroll past the errors to get to the site.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 July 2012 - 03:58 PM

Yes, so display_errors is still On. You either have to turn it off in .htaaccess, or a php.ini file or in wp-config.php. As I said before servers should have the OFF by default, but your host has it on. The whole point of the WP_DEBUG setting is to turn display_errors to on so you can see these warnings.