Jump to content


Photo

Cannot get NavBar to work properly


  • Please log in to reply
3 replies to this topic

#1 farseer

farseer

    Newbie

  • Members
  • 1 posts

Posted 10 July 2012 - 03:08 PM

I was very excited when I updated and found the NavBar which adapts to a mobile view...BUT it doesn't want to work on my site. I have my menu setup correctly with nested menu options and I ticked the box to allow dropdown menus. But my top level menus do not do anything (don't link to where they should) and when I click on them nothing happens (no dropdown appears). And when my menu swaps to mobile view and I click the icon to expand it, nothing happens.... What I want; my top level menu items should link to various things (pages/cats etc) and the dropdown menu options should appear on mouse over. Is this possible with navbar? Could you please check my site and tell me why nothing seems to be working... I am going to put back the old nav menu just until this is fixed

#2 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 10 July 2012 - 03:48 PM

The new NavBar has a 'click' to show child items. If you want dropdowns on hover, you need to use the Nav Classic menu.

#3 glennyboy

glennyboy

    Super Member

  • Members

  • 151 posts
  • Country: Country Flag

Posted 20 July 2012 - 11:08 AM

I was looking for exactly the same - drop down on hover. The new NavBar is nice but it really does need a drop down on hover - surly this is only a basic change to the code?

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 12968 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 20 July 2012 - 12:43 PM

No this is the way the menu has been created by Twitter not us and they will not be changing this functionality either. There is a post by one of the developers regarding this - http://www.markdotto...ined-dropdowns/