Jump to content


Photo

Problem with Feature background image not loading


  • Please log in to reply
6 replies to this topic

#1 tbadorrek

tbadorrek

    Member

  • Members
  • 13 posts

Posted 09 July 2012 - 03:33 PM

I'm having a very strange issue where the background image of my feature will not load because Pagelines is generating bad code. Here is the code that it is creating:
 <div class="feature-wrap wcontent" style="background: url('http://mysite.com/wp-content/uploads/2012/07/home-feature5.png) no-repeat top center">

Note that the ending quotation mark is missing from the end of the image URL.

This is odd because the image was loading fine earlier today and the ending quotation mark was showing up then! I have no idea what would cause it to stop generating that ending quotation mark.

Any thoughts?

#2 tbadorrek

tbadorrek

    Member

  • Members
  • 13 posts

Posted 09 July 2012 - 05:27 PM

Actually, this is only happening in Firefox, not Chrome nor IE. Really, really bizarre.

#3 tbadorrek

tbadorrek

    Member

  • Members
  • 13 posts

Posted 09 July 2012 - 05:37 PM

Well, this is still a bug worth noting, but I went into section.features.php and replaced the two ' with ' (HTML number for ' ), and now Firefox recognizes both of them. Seems to have solved the issue for now.

#4 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 09 July 2012 - 08:02 PM

I just attempted to recreate your issue and my code came out correctly with:

 <div class="feature-wrap wcontent" style="background: url('http://jen.staff.pagelines.com/wp-content/themes/pagelines/sections/features/images/feature1.jpg') no-repeat top center">

You may want to check your Custom CSS code as you may have an error in it somewhere.

#5 cjabaley

cjabaley

    Member

  • Members
  • 20 posts

Posted 09 July 2012 - 08:29 PM

Are you using Wordpress HTTPS? If so, revert to 3.0.4

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 13067 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 10 July 2012 - 10:33 AM

@tbadorrek Did cjabaley suggestion work ? I have no experience with that plugin.

#7 tbadorrek

tbadorrek

    Member

  • Members
  • 13 posts

Posted 31 August 2012 - 01:59 PM

cjabaley's suggestion was likely the culprit. I had been installed Wordpress HTTPS about the same time I had this problem, so that makes sense.