Jump to content


Photo
- - - - -

Images to big in iBlogPro 4


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 videopetegmailcom

videopetegmailcom

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 17 July 2010 - 12:02 PM

Hello, i want to use iBlogPro 4 for my blog but i have 2 questions: i already have 3000 messages on my blog. The maximum image width for iBlogPro 4 is 600 pixels but some of my 3000 blogpost contains images who are bigger than 600 pixels.Resizing them or edit a couple of thousands of messages is not an option. Is it possible to resize the images from for example 625 pixels tot 600 pixels by modifying some code in iBlogPro 4? Kind regards, Peter

#2 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 19 July 2010 - 07:15 AM

where are you displaying the images? i.e. What are you using to do it?

#3 videopetegmailcom

videopetegmailcom

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 20 July 2010 - 01:10 AM

Hello Andrew,

The problem is that i have a lot of pictures in my existing blogposts with an image width of 625 pixels. Problem is that they are to big for iBlogPro 4 and it's not doable to adjust thousands of blogposts by hand.

When i am using iBlogPro 4 they are cut off on the right side see the example:

Posted Image

is there any way to correct this by cropping the images by a script or adjusting some code of iBlogPro 4?

Hope you can help me out with this.

#4 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 20 July 2010 - 01:26 AM

I know this could be handled somewhere in the code that creates the image tag to add: `width="600"` But this will likely create an undesirable "stretched" look. Do you have Photoshop (if so, which version)? I can walk you through an automated way to bulk resize the images. Thanks, Bryan

#5 videopetegmailcom

videopetegmailcom

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 20 July 2010 - 03:06 PM

Hello Bryan,

if i add: img {max-width:600px;} to style.CSS the problem is fixed but i only want to use it on my blogposts. Because everything has now an image width of 600 pixels on my website.

#6 videopetegmailcom

videopetegmailcom

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 20 July 2010 - 03:13 PM

Update: solved it with adding img {max-width:600px;} to page.php Is it also possible to add this line in the custom settings?

#7 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 20 July 2010 - 05:11 PM

If you want it only on the blogposts then you can add #maincontent in front of the "img" CSS This can be applied in the THEME OPTIONS > CUSTOM CODE SECTION

#8 videopetegmailcom

videopetegmailcom

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 26 July 2010 - 12:16 AM

Hello Adam, thanks for your advice. Should i add this: #maincontent img {max-width:600px;} in the CUSTOM CODE SECTION Thanks again!

#9 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 26 July 2010 - 05:34 PM

Yeah that would do just fine.