Jump to content


Photo
- - - - -

Problem translation file Pagelines Framework 2.2.1.


  • Please log in to reply
4 replies to this topic

#1 evert100

evert100

    Super Member

  • Members
  • 156 posts
  • Framework Version:2.3.8.
  • Country: Country Flag

Posted 02 July 2012 - 02:24 PM

Hi, With version 2.1.5. i translated all i needed to dutch an saved the .po and .mo files to language folder within pagelines-customize. This prevents for being overwritten with updates. With version 2.2.1.I don't what happened but not all the strings are correct anymore. For instance viewing a category now turns back to English, while viewing an archive doesn't. Okay maybe the .pot has changed. Till now i used "translation on the fly" with a plugin, but the .po file isn't visible anymore. So i can't make further changes. Please some advice.

#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 02 July 2012 - 02:54 PM

Did you try the translation from here?

Please Login or Register to see this Hidden Content



#3 evert100

evert100

    Super Member

  • Members
  • 156 posts
  • Framework Version:2.3.8.
  • Country: Country Flag

Posted 02 July 2012 - 03:02 PM

No i didn't because i made my own translation file. As i said it was perfect till 2.1.5. What happened as i described? Is there a change in the .pot file each time the framework gets upgraded? Hope not because it's a lot of work. BTW i use the codestyling localization plugin for translation "on the fly", after finished i move through ftp the files to the customization plugin from pagelines. Was a great workout, but is dead now. Please: is the .pot file changed or the relation to the plugin from pagelines?

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 02 July 2012 - 03:31 PM

evert the pot file changes with every revision, thats the point of it, it contains all translatable strings. The translation site always has the latest pot added, so if you use that, and help translate it, you will always be up to date. 2.1.5 po/mo will not work with 2.2

#5 evert100

evert100

    Super Member

  • Members
  • 156 posts
  • Framework Version:2.3.8.
  • Country: Country Flag

Posted 02 July 2012 - 03:58 PM

Thanks. =; I will look into that. Cheers.