Jump to content


Photo

Store displays errors


  • Please log in to reply
6 replies to this topic

#1 norwichsteinerschool

norwichsteinerschool

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 June 2012 - 09:07 AM

Hi, I'm getting errors when I go to the store tab within PL admin. My config is wp3.4 & pl 1.1.4, with a free pl account set. Errors as follows: http://paste.pagelines.com/6r2 WP debug is off... yali:~# grep ^display_errors /etc/php5/cgi/php.ini display_errors = stderr Apache should have arranged for stderr to go to my error.log file, so as long as php doesn't do anything odd with it, I'll get php errors in the error.log. /wp-admin# grep ini_set *.php plugins.php: @ini_set('display_errors', true); //Ensure that Fatal errors are displayed. From what I can see the plugin framework deliberately re-enables the displaying of errors. I don't think I should have to disable this. Could my instal of "Lite" be trying to read an unspecified file? Any leads appreciated. d

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 20 June 2012 - 10:00 AM

Hi, The latest stable release of PageLines Lite is version 1.1.3, therefore have you downloaded the SVN version ?

#3 norwichsteinerschool

norwichsteinerschool

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 June 2012 - 12:51 PM

Hi Danny, I was on 1.1.3 and had the same problem. When I went to pl dash I saw 1.1.4 so thought it was worth trying it out. Any ideas?

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 20 June 2012 - 01:20 PM

display_errors should be off, completely in a production machine. setting WP_DEBUG to true in wp-config.php will force it back on.

#5 norwichsteinerschool

norwichsteinerschool

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 June 2012 - 02:31 AM

config : define('WP_DEBUG', false); plugin.php line 139: @ini_set('display_errors', true); //Ensure that Fatal errors are displayed. errors in store tab still persist even when plugin.php is set to false.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 June 2012 - 03:36 AM

Please dont edit core wp files. Ever. The code you grepped in wp-admin is only executed during plugin install. As i said before display_errors is On on your server, turn it off with : @ini_set('display_errors', true); add it to wp-config.php if you do not have access to php.ini

#7 norwichsteinerschool

norwichsteinerschool

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 June 2012 - 10:09 AM

Thank you Simon, define('WP_DEBUG', false); @ini_set('display_errors', false); in wp config cures errors in store.