Jump to content


Photo
- - - - -

Problems with WP 3.4 and The Store


  • Please log in to reply
7 replies to this topic

#1 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 14 June 2012 - 11:52 PM

Friends, We've taken note of several discussion topics following the upgrade of WordPress 3.4. Evidently, in some cases, the PageLines Store yields some errors.

Generally, this is the result of a minor conflict brought to light if your site has debugging activated. Many of us don't even realize it is active as a result of settings in cPanel.

To make sure debug is off, please edit your wp-config.php file via FTP as follows:

// make sure wordpress debug is off

Please Login or Register to see this Hidden Content



Add the following code found below to wp-config.php on the next line:

// turn off PHP debugging, should be off always on production servers.

Please Login or Register to see this Hidden Content



With debugging off, the errors will not show, PageLines will work and your site's Store should function as normal.

We apologize for any inconvenience. An upcoming upgrade will resolve the matter fully.

#2 batman

batman

    Bat Learning

  • Members

  • 2085 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 15 June 2012 - 12:04 AM

Dear rangelone Thanks, works perfect :)

#3 bsaul

bsaul

    Advanced Member

  • Members

  • 76 posts
  • LocationKent, UK
  • Country: Country Flag

Posted 15 June 2012 - 07:56 AM

Phew - thank you. That's resolved the immediate issue. Will holdfire on updating the rest of my sites until the update is ready.

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 15907 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 June 2012 - 11:42 AM

@Bsaul I accepted your answer to resolve the moderation que.

#5 evoke2

evoke2

    Member

  • Members
  • 19 posts
  • LocationPembroke Pines, FL
  • Country: Country Flag

Posted 15 June 2012 - 01:51 PM

Hi, I just tried this code on my wp-config.php file as seen below, however i am still getting this even after I clear my cache (Unable to locate the main framework files! Make sure the parent theme folder is named correctly.) ___________________________________________________________________________ define('WP_DEBUG', false); // turn off PHP debugging, should be off always on production servers. @ini_set('display_errors',0); /* That's all, stop editing! Happy blogging. */ ____________________________________________________________________________ Please help, I have a few sites on Pagelines and I do not want to update Wordpress 3.4 until I can figure out the issue here. Thank you.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 June 2012 - 02:29 PM

All the child themes were updated for wordpress 3.4, the file changed was setup.php, either redownload the base theme, or copy setup.php from

Please Login or Register to see this Hidden Content



#7 pehja

pehja

    Advocate

  • Members


  • 560 posts
  • LocationSweden
  • Framework Version:Pagelines v2.4.3 and DMS
  • Country: Country Flag

Posted 15 June 2012 - 06:08 PM

@Simon, this is not correct. I did what you said but still the same problem. My debug was OFF on both cpanel and on the site settings. But this string : // turn off PHP debugging, should be off always on production servers. @ini_set('display_errors',0); did the trick!

#8 mundocaco

mundocaco

    Advanced Member

  • Members

  • 37 posts
  • LocationCanary Islands
  • Framework Version:2.4.4 - DMS
  • Country: Country Flag

Posted 19 June 2012 - 04:08 PM

Dany and Pagelines team, I really love you. Works! :D