Jump to content


Photo
- - - - -

Error Message In Store


  • Please log in to reply
19 replies to this topic

#1 zabby

zabby

    Member

  • Members

  • 19 posts
  • Framework Version:platform pro
  • Country: Country Flag

Posted 14 June 2012 - 01:14 AM

Hello. I just updated wordpress and now I'm getting a bunch of errors like this when I go to pagelines -> store in my wp dashboard. I have the base theme installed. Thanks in advance. -Natalie

#2 zabby

zabby

    Member

  • Members

  • 19 posts
  • Framework Version:platform pro
  • Country: Country Flag

Posted 14 June 2012 - 01:14 AM

This is the error: Warning: fopen() [function.fopen]: Filename cannot be empty in /home/content/47/8949447/html/wp-includes/functions.php on line 3373

#3 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 14 June 2012 - 01:27 AM

Hey there Zabby! Sorry you're having troubles! We've been expecting 3.4 for quite some time and have been prepared for this. I would make sure that, debug is turned off in wp-config.php. If you have no idea what i"m talking about, then your server may have this on by default, which is poo. Where are you hosted, and if you have no idea what wp-config.php is, would you mind emailing them and asking if debug is on by default? It should not be, on a production server. Let us know how it goes. Nick

#4 zabby

zabby

    Member

  • Members

  • 19 posts
  • Framework Version:platform pro
  • Country: Country Flag

Posted 14 June 2012 - 02:05 AM

Nick, I'm hosted with GoDaddy. I cracked open the wp-config.php and debug is off [false] by default. Any other ideas? Thank you! Natalie

#5 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 June 2012 - 02:50 AM

Try deactivating your active plugins to see if the problem persists (better to get that possibility out of the way).

#6 zabby

zabby

    Member

  • Members

  • 19 posts
  • Framework Version:platform pro
  • Country: Country Flag

Posted 14 June 2012 - 03:30 AM

No luck.

#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 15788 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 14 June 2012 - 11:07 AM

Hi Zabby, Did you email GoDaddy! as Nick suggested and ask this if debug is on by default ?

#8 bsaul

bsaul

    Advanced Member

  • Members

  • 76 posts
  • LocationKent, UK
  • Country: Country Flag

Posted 14 June 2012 - 12:29 PM

Same here on a client's UK server (not GoDaddy) - debug is definitely off. Repeating the following 3 errors: Warning: fopen() [function.fopen]: Filename cannot be empty in /home/mutibok1/public_html/wp-includes/functions.php on line 3373 Warning: fread(): supplied argument is not a valid stream resource in /home/mutibok1/public_html/wp-includes/functions.php on line 3376 Warning: fclose(): supplied argument is not a valid stream resource in /home/mutibok1/public_html/wp-includes/functions.php on line 3379 Will test on another later - different server.

#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 15788 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 14 June 2012 - 12:40 PM

@bsaul @zabby Would it be possible to provide the PHPinfo of your server please. So we can see if its a server configuration error.

#10 fjislander

fjislander

    Newbie

  • Members
  • 6 posts

Posted 14 June 2012 - 12:51 PM

I am also getting similar errors and I am hosted with Just Host as a reseller.

#11 bsaul

bsaul

    Advanced Member

  • Members

  • 76 posts
  • LocationKent, UK
  • Country: Country Flag

Posted 14 June 2012 - 01:36 PM

Just tested on my own server which runs the following, and getting same error in the Store. Option Configured Value Default PHP Version (.php files) 5 PHP 5 Handler suphp PHP 4 Handler none Apache suEXEC on Apache Ruid2 off

#12 driesup

driesup

    Newbie

  • Members
  • 4 posts
  • Country: Country Flag

Posted 14 June 2012 - 08:28 PM

Same error, host priorweb.be

#13 evert100

evert100

    Super Member

  • Members
  • 156 posts
  • Framework Version:2.3.8.
  • Country: Country Flag

Posted 14 June 2012 - 08:35 PM

It's a sad thing. I already mentioned this error on the 5th of May in this forum as we had wp 3.4 beta 4. So far no pagelines update. Hey guys wake up! When will update 2.2 arrive? At least give your customers a warning NOT to upgrade to wp 3.4 because you cannot enter the store anymore. So far as i can see everything else is working properly. Please quick action required. It doesn't have to do anything with a hoster or plugins as far as i tested some weekes ago. It just has to do with the fact that pagelines 2.1.6. is NOT compatible to wp 3.4. So give us an update this week please! Cheers, Evert

#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 14 June 2012 - 09:55 PM

See

Please Login or Register to see this Hidden Content

If you have cPanel, you need to turn Debug off. It may be in either cPanel or in your wp-config.php file that debug is turned on. When it is, WordPress (not PageLines) generates a bunch of errors. As a result, some things won't work and in this case, it's manifesting in the store. I had some errors myself (dozens) and went into cPanel, turned off debug and they vanished. The store works fine now. Please let us know.

#15 batman

batman

    Bat Learning

  • Members

  • 2078 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 June 2012 - 10:33 PM

Hello rangelone I have the same error and I have my wp-config defined define ('WP_DEBUG', false); Where am I making the mistake.

#16 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 14 June 2012 - 11:11 PM

If you have a phpinfo.php file in your site, you will be able to see if debug is on (see the screenshot above). If it's set to true or on, then it's likely in cPanel or other hosting administrative tools (Plesk, etc).

#17 batman

batman

    Bat Learning

  • Members

  • 2078 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 June 2012 - 11:21 PM

I'll try to look in my control panel tomorrow (with more time) Only happens in the store, everything else works fine. Thank you very much.

#18 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 15 June 2012 - 03:09 AM

Let us know what else you find out (if anything).

#19 batman

batman

    Bat Learning

  • Members

  • 2078 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 15 June 2012 - 10:24 AM

Hi Catrina: Without modifying the wp-config as instructed Mr. rangelone only I see the error in the Store with the child theme, everything else is working properly.. Adding in the wp-config.php file via FTP (Mr. rangelone "Announcement") / / Make sure debug is off wordpress define ('WP_DEBUG', false); Add the Following code found below to wp-config.php on the next line: / / Turn off PHP debugging, Should be off always on production servers. @ ini_set ('display_errors', 0); The error disappears and the Store is working properly. Many thanks for your concern. Carlos

#20 Danny

Danny

    Is Awesome!

  • Moderators
  • 15788 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 15 June 2012 - 10:38 AM

Hi all, Please see this forum topic here -

Please Login or Register to see this Hidden Content