Jump to content


Photo
- - - - -

News/blog page issues


  • Please log in to reply
5 replies to this topic

#1 nfp1900

nfp1900

    Advocate

  • Members

  • 285 posts
  • LocationLondon (the original one)
  • Framework Version:The Latest
  • Country: Country Flag

Posted 07 June 2012 - 09:54 PM

I had to add a news section to this site - so I created a page called NEWS and in the WP reading settings selected it so all posts would appear there. I see that Pagelines turns this page into a 'Blog' template automatically and I was able to style it through the Pagelines Meta for the 'Blog Page'. But when a post is created, Pagelines seems to give these pages the template 'Blog Post' but where do you style these pages? I want to be able to select the same feature header - if this is possible. Also, how do you get widgets to appear in the sidebar of the main 'Blog Page' ? Using widget logic I get them to appear for the posts but for some reason not on this main page. Sorry if these are dumb questions but I couldn't find any docs on this part of the set-up. Have I gone about this in the wrong way?

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 June 2012 - 02:26 AM

First, let me start off by saying that when you selected "News" as a static blog page in Dashboard > Settings > Reading, WordPress, not PageLines, designates that it's the blog. We merely apply a basic template to that page. If you go to Dashboard > PageLines > Templates, you can apply various elements to the Page Template, but also to the Content Template for each of these. The sidebars are generic to all template configurations, so whatever sidebars you assign there should appear. I don't know what coding you gave to Widget Logic. If it's a generic restriction, then widgets won't appear on that page. but normally, the should. In Dashboard > PageLines > Meta > Blog Page, did you, by any chance, hide sidebars by default for that template? I'd suggest going there, making sure that you have the correct layout selected, and that none of the elements you want are hidden. Did you mean "feature slider" instead of "feature header"? If you want a feature slider in a page, make sure the template has the slider, then, inside the post, you may select the feature set you wish to apply to that particular page. Let us know how that goes and if we can assist further. Nice looking site!

#3 nfp1900

nfp1900

    Advocate

  • Members

  • 285 posts
  • LocationLondon (the original one)
  • Framework Version:The Latest
  • Country: Country Flag

Posted 08 June 2012 - 12:52 PM

So I fixed the features selection on the blog posts by using the Pagelines>Meta>Site Defaults>Features and selecting the one I needed which has worked. Since all the other pages have their own meta selection this gets round the issue of selecting it for each post (I need it to be idiot proof for when the client posts their stuff). Visual logic I adjusted to show all then 'except' all the pages I didn't need which worked - for some reason the page designated in WP as the posts page (in this case NEWS) doesn't respond to the logic in the normal way.

#4 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 08 June 2012 - 03:06 PM

Did you get all of the issues resolved or do you still need assistance? If you consider this topic closed, please "accept" an answer - thanks!

#5 nfp1900

nfp1900

    Advocate

  • Members

  • 285 posts
  • LocationLondon (the original one)
  • Framework Version:The Latest
  • Country: Country Flag

Posted 11 June 2012 - 09:38 AM

It would be useful to have some clarification/documentation on how these blog pages work. At the moment there is only some info the global settings for Blog And Posts. There are templates for Blog and Blog Post but overall Meta settings only for Blog Page. From what I can see, the Meta for Blog Page only customises the single first page of your blog page specified in Wordpress under the reading settings. There doesn't appear to be a global settings meta for any posts, these have to be handled individually. Is this right?

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15026 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 11 June 2012 - 12:43 PM

Hi, You have to handle posts on a post by post basis at this moment in time. I have however, added this as a customer suggestion for my weekly report.