Jump to content


Photo
- - - - -

Facebook OpenGraph tag for Wistia


  • Please log in to reply
7 replies to this topic

#1 f451

f451

    Advanced Member

  • Members
  • 41 posts
  • LocationInverness Florida
  • Country: Country Flag

Posted 23 May 2012 - 02:19 PM

I am trying to put a head tag on a specific page for a Facebook Opengraph tag for a wisita video embed. Wistia documentation says. "Posting to Facebook from your website Maybe you want to post to Facebook, but you want it to point back to your website? If so, you can use the OpenGraph tags we produce for 'public' videos to accomplish this. Facebook uses the OpenGraph tags to specify which media/content from the website should be posted. To do this, first embed the video on your website. Next, make the Project your video is contained in a ???Public??? project, and add a description (as detailed in the video above). View the source on the media page, and look for '. These are the OpenGraph tags we have created for your video! Add these to the of your external website, and then share the URL of that page on Facebook. " I have done this and the tag is What is the simplest way to get this and other on the pages with the free videos I want to share on Facebook. I looked over the forum notes and tried a few plugins but I not able to get this solution in place yet.

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 23 May 2012 - 06:54 PM

In Dashboard > PageLines > Settings > Custom Code > Header Scripts did you add the complete code there? That's where the meta tag goes. Also, in Dashboard > PageLines > Settings > Header And Footer, under "Facebook Open Graph" did you check the box for "Enable Facebook Open Graph data?"

#3 f451

f451

    Advanced Member

  • Members
  • 41 posts
  • LocationInverness Florida
  • Country: Country Flag

Posted 23 May 2012 - 08:25 PM

Well this part works. The tag is now on the pagelines page. on page

Please Login or Register to see this Hidden Content

but for some reason Facebook doesn't pick up the video image when I share the page on my Facebook page. Any ideas what could be wrong.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 23 May 2012 - 08:49 PM

I'm afraid I know nothing about OpenGraph. You may need to check some documentation for that. You'll find some info here:

Please Login or Register to see this Hidden Content



#5 f451

f451

    Advanced Member

  • Members
  • 41 posts
  • LocationInverness Florida
  • Country: Country Flag

Posted 25 May 2012 - 01:25 PM

The problem is with pagelines-wordpress. Here is the reply from the Wistia support and it is correct there are two entries in the head. Why? thanks as always for you help. " Hi Michael, It looks like Facebook isn't counting the page content because there are duplicate OpenGraph tags of the same value on the page (don't ask me why this is a problem for them??¦they are weird like that). Specifically, it looks like there are multiple og:title, og:description, og:type, and og:url tags. If you remove the duplicates, I believe it will work properly. One issue with this is if you've already submitted once, it will remain cached - so once you remove the duplicate tags, test it with someone else "Like"ing the page.

#6 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 25 May 2012 - 02:12 PM

You are correct that it will receive errors with 2 titles. I assume you have the PageLines OpenGraph setting enabled so that is where the second one comes from. The problem with removing that setting is that you will remove the data from all content that isn't video related. Rather than trying to add something to make the Wistia thing work, why don't you just change the title of the post from "Free Videos" to "Interview Molly Stanek AAC-11"?

#7 robbienorris

robbienorris

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 28 August 2012 - 06:18 PM

@Rangelone... above you stated: In Dashboard > PageLines > Settings > Custom Code > Header Scripts did you add the complete code there? That's where the meta tag goes. Also, in Dashboard > PageLines > Settings > Header And Footer, under "Facebook Open Graph" did you check the box for "Enable Facebook Open Graph data?" I navigated here and there is no check box? Rob

#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 28 August 2012 - 10:18 PM

Here's one shot of where you should find it:
Posted Image
and what you should see:
Posted Image
This should be checked.