Jump to content


Photo
- - - - -

Trouble with Home Page


  • Please log in to reply
5 replies to this topic

#1 jmlavi13

jmlavi13

    Newbie

  • Members
  • 5 posts
  • LocationCleveland
  • Framework Version:2.4
  • Country: Country Flag

Posted 19 May 2012 - 02:37 PM

The Site URL is what I would like to be my Home page, however, when Home is clicked on the menu it does not go back this page. It is because I have selected the Home page to be the Blog. I can not find a command that will allow my Blog and Home page to be the same page, I get an error. I want News page to show blogs too. Any help would be great!

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 May 2012 - 04:51 PM

In Settings > Reading you need to make sure that your home page is set to show latest posts.

#3 jmlavi13

jmlavi13

    Newbie

  • Members
  • 5 posts
  • LocationCleveland
  • Framework Version:2.4
  • Country: Country Flag

Posted 20 May 2012 - 12:09 PM

That is how I have it set up. When you enter the URL it is correct, my problem is when you navigate through the site, and click Home, you do not return to the Blog page. I want the Home and the Blog page to be the same? Thanks in advance...

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 20 May 2012 - 05:06 PM

Are you using a custom menu to generate your main navigation? Right now your "Home" link is set to go to a page called "News" when it should actually go to the home page.

#5 jmlavi13

jmlavi13

    Newbie

  • Members
  • 5 posts
  • LocationCleveland
  • Framework Version:2.4
  • Country: Country Flag

Posted 21 May 2012 - 02:50 AM

You are correct, that is because I want my latest posts to be my Home page. In >Settings >Readings, I have set up the front page to be the latest posts. It will not allow me to have the Home page be both the Front page and the Blog Page. Again, I want my current front page to be accessed by clicking Home on my menu, too.

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17124 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 May 2012 - 10:48 AM

Hi, You need to create a custom menu, read through the link below, which has instructions on how to create your custom menu. http://en.support.wordpress.com/menus/ When creating your Homepage menu link, use the "Custom Links" option.