Jump to content


Photo
- - - - -
Resolved

post clips size



  • Please log in to reply
40 replies to this topic

#21 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 23 May 2012 - 02:22 AM

Filters are discussed more in depth in this WordPress documentation:

Please Login or Register to see this Hidden Content



#22 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 23 May 2012 - 11:59 PM

do you mind to give me an working example of this filter, so i could play with this code? i have no idea about php.

#23 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 May 2012 - 02:22 AM

Unfortunately, I'm not much of a PHP person either and I'm not a developer. : I think @simon would be better at explaining. An explanation from me may not be the best! Tutorials that describe WP filters more in-depth and have examples may be helpful, though.

#24 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 26 May 2012 - 06:25 PM

no sign from @simon ...

#25 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 26 May 2012 - 07:03 PM

i explained 5 times what i want to do, and i didn t get a solution for 9 days now.. this is a bug in platform framework, and instead of giving tips, i would expect to have this problem fixed by developers! am i wright?

#26 Danny

Danny

    Is Awesome!

  • Moderators
  • 13067 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 27 May 2012 - 10:45 AM

Hi Jan, First of all I apologise that I assumed this was a bug which it isn't as Simon mentioned, the "On Top" is supposed to be full image. Therefore, nothing needs fixing. If you wish for "On Top" to be changed slightly so that it uses thumbs instead of full images, reply her confirming and I will add it to the PageLines Tracker for you on your behalf as a Feature Enhancement.

#27 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 27 May 2012 - 09:25 PM

therefore instead of little clips my page loads 6 full images and resize them by css to little clips. congratulations both to you @danny and @simon yes, as you could notice, since may 17th i m kindly asking for this slightly change, so do not hesitate to add it to tracker... how long will it take to get it fixed? i am tired of talking about this for so long.

#28 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 27 May 2012 - 10:15 PM

We cant fix something that is not broken. The 'on top' image setting uses the full image, thats all it does. If you want to change the image markup i already suggested using a filter, thats what they are provided for. We cant add a new option every time somebody wants the framework to do something non-standard.

#29 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 29 May 2012 - 09:05 PM

thank you @simon , can you give me example of filter with 200 x 200 px thumb? I still think you r wrong. There is an option "Number of Full Width Posts" in panel, and only the number you select there should be full size. Don t argue with me, use your intelligence instead and you will find out why am I right. I am very disappointed that you are are not open for suggestions to improve the system. I never siad it is broken, i m just trying to explain you that it is not optimized enough and slows down page loading. Give me one reason why should framework load full size images and resize them down by css code afterwards? Don t be ridiculous, just admit i am right.

#30 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 31 May 2012 - 04:13 PM

@jankowalski Send me your URL via PM with the thumb on top as your current layout, as well as your desired thumb size, and I'll see if I can hack it with CSS, if you'd like.

#31 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 08 June 2012 - 02:51 PM

thats the solution. Took a while but thank you both to @simon and @simple_mama

Please Login or Register to see this Hidden Content


topic closed!

#32 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 August 2012 - 04:07 PM

why is it that every time i look for help in the pagelines forum i find myself reading these absolutely awkward threads. people are asking for help and pagelines support just boasts of arrogance, unwillingness to understand their customers and incompetence. i like the pagelines framework, but most of the support people are just doing an awfully bad job at helping people and a GREAT job at making help-seekers feel like fools. this forum is the nightmare of any manager who takes customer service seriously. it is also the nightmare of any paying customer (and we pay A LOT!).

#33 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 30 August 2012 - 05:30 PM

@skyrocket Thank you for taking the time to leave a comment. I do understand what you mean. What jankowalski was asking is not a standard feature of PageLines Framework but I did work with him via PM and reached out to one of our developers for assistance. The code you see above was the solution to his issue. I wanted to make sure he received the proper solution and didn't want to just leave him hanging. Hope that helps clear up this thread a little bit. :)

#34 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 30 August 2012 - 05:32 PM

I have the same feeling, This support on this forum is just horrible. In so many topics I had to explain to 3 diferent persons the same thing, and every next guy from customer service don t even read the conversation from before, or read but have troubles in understanding.. HORIBLE this topic at least was solved, but i have so many topics on this forum that i didn t get an aswer for simple requests...;(

#35 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 30 August 2012 - 05:35 PM

Thanks for your follow-up @jankowalski - I have forwarded this topic to my supervisor so she can take a look.

#36 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 August 2012 - 05:49 PM

The only reason this thread was helpful for me was because JANKOWASLKI posted the solution (which is not his responsibility). But I'm actually not just referring to this thread. Here's another attempt of JANKOWALSKI to find an answer to his question and I find RANGELONE's attitude unbelievably rude and plain ridiculous. I had a flashback from kindergarten when i read this:

Please Login or Register to see this Hidden Content

Why do you keep asking for URLs? Registered users already proved that they bought pagelines and in most cases it just seems like you guys are trying to push an answer away and hope the user doesn't respond back. @simple_mama: Thanks for your positive response!

#37 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 30 August 2012 - 06:54 PM

Asking for a URL has absolutely nothing to do with looking to see who owns what. We ask for the url as a lot of 1st time developers start with installing 45 plugins that do the same thing, 15 cache plugins and THEN start developing stuff by editing the main css files. Looking at the page source is a quick way of finding out 90% of the problem. Anyway, closing this topic as it was resolved long ago with the solution I provided by email.

#38 marcelotavares

marcelotavares

    Member

  • Members
  • 17 posts
  • LocationSão Paulo, Brazil
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 11 November 2012 - 04:59 PM

Hi jankowalski, I'm having the same difficulty that you had, I want to customize the size of thumbs in my blog.

Where do you paste the code below?

add_filter( 'post_thumbnail_size', 'my_post_image_size' ); function my_post_image_size( $size ) {
if ( is_single() )
return $size;
else
return 'medium';}

I put it on Custom Code under Site Options but no with no changes in my thumbs. Here my website:

Please Login or Register to see this Hidden Content



Thanks,
Marcelo

#39 jankowalski

jankowalski

    Advocate

  • Members
  • 344 posts
  • Country: Country Flag

Posted 11 November 2012 - 05:39 PM

you have to put it info function.php in your child theme folder
  • marcelotavares likes this

#40 marcelotavares

marcelotavares

    Member

  • Members
  • 17 posts
  • LocationSão Paulo, Brazil
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 11 November 2012 - 06:14 PM

Thanks Jankowalski, now it seems to work with the medium size dimension set on Wordpress Media Settings page!





Also tagged with one or more of these keywords: Resolved