Jump to content


Photo
- - - - -

Unwanted characters after editing functions.php in Pagelines Customization plugin


  • Please log in to reply
12 replies to this topic

#1 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 09 May 2012 - 06:53 PM

I have Pagelines Customize installed and was trying to add a google font to functions.php in plugins>pagelines-customize. I followed instructions found here:

Please Login or Register to see this Hidden Content

Now my site is broken and displaying unwanted characters in the head of the site. I have reinstalled Wordpress without success and my next step was to re-intall the plugin but I can't figure out how to do that. Mostly I need to compare the original functions.php file with the one I have to make sure there are no syntax errors. I also had a plugin (WP Google Fonts) installed that I am worried may have created a conflict. I deactivated it, deleted and physically removed it from the plugin directory and returning it to the state that it was in when I first observed the unwanted characters. While I can read PHP and make adjustments to it and am generally able to stay away or correct syntax errors I don't know enough about this particular issue to resolve it. Any suggestions would be greatly appreciated.

#2 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 09 May 2012 - 07:25 PM

@ehand: My first question is why would you use a Google Fonts plugin when PL supports Google Fonts out of the box? You should be using the Base Theme. If that is already the case, you can replace the corrupt functions.php with an original - which you will get when unzip it to your desktop. If you somehow muddled up your functions.php, there should be no need to reinstall WordPress. You didn't happen to backup functions.php before you made the coding change did you? (You will next time!).

#3 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 09 May 2012 - 07:45 PM

@Webwerx Thank you for your input. I had a back up copy of my functions.php file but my app that was holding it in an untitled text froze and I lost that backup when I had to restart the app. I used the Google Fonts plugin because I did not have an entire list of available fonts and was looking for resources for that. Pagelines for what ever reason only gives a partial list. It seemed the natural thing to try and it didn't occur to me that it would break something that I wouldn't be able to fix by simply unistalling it. I am not using Base Theme I am using the Pagelines Customization plugin which can be edited directly just as Base Theme can be. One of the issues here is that the Pagelines Customization plugin doesn't seem to have a download page either at WordPress or at Pagelines. So I can't redownload and compare my files. Is there anyone else who has suggestions that might help me out in this situation?

#4 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 09 May 2012 - 07:55 PM

YA... install the Base theme, and activate it. Then copy any custom CSS you have applied in Pagelines, and paste it into the custom.css of the Base Theme. As soon as you activate the BAse Theme, your site should come back.

#5 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 09 May 2012 - 08:41 PM

Ok, I tried that. But when I clicked the activate button this is the code I get:

Please Login or Register to see this Hidden Content


I got this before and went to line 866 on pluggable.php to see if I could identity the issue. The chunk of code found there is for re direct function.

Please Login or Register to see this Hidden Content


Also, the unwanted characters are showing up on the administrative side of the site as well.

#6 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 09 May 2012 - 09:12 PM

Have you tried any other theme? Like TwentyTen?

#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 May 2012 - 09:37 PM

Gentlemen, the code you looked at in the forum (as stated in the original part of this topic) dated from PlatformPro and isn't applicable to PageLines Framework. The Google Fonts plugin is really most applicable here. Most of the fonts shown here:

Please Login or Register to see this Hidden Content

are included, but Google adds to the list often and we manually add them to the plugin. If you see a font you like, but it's not in our plugin, just drop us a note and we'll endeavor to add it to an update, as soon as those are ready.

#8 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 09 May 2012 - 10:28 PM

@WebWerx That was a good suggestion and got exactly the same error code.

@rangelone Are we talking about the the Typography Setting under Global Settings? From what I can see there are less than 30 font families from google there and there are over 500 font families on the on the link that you provided. Am I missing something?

I'm aware that the documentation is from platform pro but the instructions in functions.php in the Pagelines customization plugin say that I can add chosen fonts there.

Here is the functions.php in it's entirety, Can anyone see anything wrong with this page?

Please Login or Register to see this Hidden Content


Does anyone have any idea why this might be happening to the head of the site?

#9 WebWerx

WebWerx

    Advocate

  • Members
  • 546 posts
  • LocationCanada
  • Framework Version:2.2
  • Country: Country Flag

Posted 09 May 2012 - 11:06 PM

@ehand: If you are saying that the error you outlined is persisting when you change the site theme to something like Twenty Ten, then your issue is with the Wordpress core not PL. Activating a different theme takes the functions.php you mention out of the equation. @rangelone: Do you agree?

#10 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 10 May 2012 - 12:31 AM

@WebWerk When I change the site to Twenty Ten the unwanted characters go away. When I change the site to either Pagelines Base or Pagelines I see the unwanted characters. But I was seeing them still on the administrative side of the site no matter what I did and I was also seeing the before mentioned error. However, what I figured if I logged out and back in with the Twenty Ten theme activated the unwanted characters went away on the administrative side as well. So now I know that it is definitely Pagelines. But it's showing up in both the Pagelines Base and the regular Pageline's theme. This leaves the Pagelines customization plugin (which is what I originally thought) as the possible culprit. From there I have deactivated the plug in and all is fine. However, I still need the CSS in that plug in and need to reinstall it. And yes, I have the CSS backed up. @rangelone This brings me back to my original questions and request. Where can I download the page lines customization plugin? Seems the only way to get this plugin is through the store on the administrative side of my site. If my site already has it installed then there is no way to redownload it.

#11 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 10 May 2012 - 02:28 AM

The PageLines Customize plugin is only available from the Store (there isn't a place where it can be downloaded for manual installation). It probably won't let you re-download because it's already installed, so if you have the CSS backed up already, you should be able to paste that CSS back in after you delete and re-install the plugin.

#12 ehand

ehand

    Member

  • Members
  • 11 posts

Posted 10 May 2012 - 03:52 AM

@catrina Thanks! That is exactly what I did. Now if I could just get BBEdit to stop loading the CSS page that is has cached and give me the one that is actually on the server! Thanks everyone for your help. This issue is resolved. I deleted Pagelines Customization plugin and the re-installed it. That fixed the problem which was somewhere in functions.php. But because I didn't have the original file I couldn't compare.

#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 15702 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 10 May 2012 - 10:02 AM

Hi ehand, I have just read through this topic and I agree with Rangelone, we have a free plug-in available on the store called Google Fonts. Once this plug-in is installed and activated it adds over 400+ fonts to your Typography drop down menu. I have provided you with a link to the plug-ins store page, remember you can install this within your Wordpress installation.

Please Login or Register to see this Hidden Content