Jump to content


Photo
- - - - -

Horizontally Algin JigoShop Featured Shortcut Code


  • Please log in to reply
8 replies to this topic

#1 chules

chules

    Super Member

  • Members

  • 150 posts
  • Country: Country Flag

Posted 09 May 2012 - 06:50 PM

I am working on the front page of a new website. I want to display on the home page 4 Jigoshop products that are horizontally aligned just as they are when you click the link to shop at,

Please Login or Register to see this Hidden Content

I added the following code into my home page but the products are displaying vertically and not horizontally. Does anyone know how I can simply display these featured items horizontally . Here is the code I am using. [featured_products per_page="12" columns="4" pagination="yes"]

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 May 2012 - 08:30 PM

I think this question is really one for JigoShop. We only provide an integration. How JigoShop displays products via their shortcode is something they'd have to support. Have you written to them or posted on their forum?

#3 chules

chules

    Super Member

  • Members

  • 150 posts
  • Country: Country Flag

Posted 10 May 2012 - 12:58 AM

From what I see I believe this is related to Platform Pro. If I switch templates the shortcode code does display horizontally? I will confirm with Jigoshop anyway

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 10 May 2012 - 02:33 AM

Let us know what they say

#5 chules

chules

    Super Member

  • Members

  • 150 posts
  • Country: Country Flag

Posted 16 May 2012 - 04:26 AM

Here is the response I received from JigoShop tech support. As suspected I believe this issues is related to Pagelines. See below "I see the issue now, it's due to frontend.css being disabled in your home page, I'm not sure why as I can't replicate it my end but you could just paste the contents of frontend.css into your themes css file. That will fix it." Not sure what they mean here Chules

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15653 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 May 2012 - 11:14 AM

Hi Chules, I have just completed a test by adding the shortcode to a page and there does seem to be an error. I will bring this to the developers attention for you. I have bookmarked this topic!

#7 gigglingbob

gigglingbob

    Member

  • Members
  • 12 posts
  • LocationNairobi
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 26 May 2012 - 05:25 AM

Has anyone come up with a fix for this problem? Am having the same issue

#8 kakadong

kakadong

    Super Member

  • Members

  • 112 posts
  • LocationTaiwan

Posted 26 May 2012 - 09:44 AM

Use This :
[featured_products per_page="4" columns="4" pagination="yes"]

You have to use the same number of per_page and columns

Then , Because of the deactivation of pagelines for jigoshop plugin (it turns off the frontend.css ),
you should add frontend.css into your style.css . Maybe a little work is needed .(somthing like the word color)
Then you should be fine.

Take a look of my demo site : www.soho-kakadong.com/demoshop

in the middle and bottom
there are two section of recent products and feature products .


I see the issue now, it's due to frontend.css being disabled in your home page, I'm not sure why as I can't replicate it my end but you could just paste the contents of frontend.css into your themes css file. That will fix it.


Copied from jigoshop premium support. (I am a premium customer of both PL and Jigo)

#9 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 26 May 2012 - 04:46 PM

@kakadong Thanks for posting a solution