• 0
Sign in to follow this  
Followers 0

How do I reset static home page as a blog?

Question

Posted · Report post

I'm not sure if this is a Pagelines question or a Wordpress question. When I initially set up the site I'm working on I set the home page as a static page through Settings>Reading> a static page. I would like to change the home page to a blog page with Banner and Feature sections. I can't figure out how to add a blog to the already established static home page. Can anyone tell me how to do this or direct me to the right resource that explains how to do this? Thanks!

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Posted · Report post

Change your Reading settings so that the front page shows your latest posts and in Templates settings, customize the template areas for the page type "Blog" by adding the sections you want: http://www.pagelines.com/wiki/How_to_Use_the_Template_Setup

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you, Catrina. That is initially what I tried to do. It seemed the like the right route. However, after setting up the blog page in templates I can't choose blog from the template menu on any of the pages I have set up. In fact, my only choices from the template menu are Custom, Default and templates 1 through 5.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That's correct. Those are the page templates. There's no selection of a Blog Page template as it's a default. All you need to do is select a template from those available and add any elements to that in the Templates area (such as Carousels, Boxes, etc.). The Blog Page only pulls the loop and really doesn't do anything else.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you rangelone. That explains some of why I can't add a blog page. I'm still having trouble figuring out how to put a blog on the home page. I'm not sure what I need to add to the page template to have the blog show up. None of my choices for the page template area are blog. I see things like Carousels, Boxes and Features but no blog or blogroll. I know I'm missing something but I just don't know what.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ah, I see what you've done now. The templates are for regular pages and a page with posts doesn't count as a "regular" page. Are you trying to add posts to a regular page?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@catrina By 'regular' do you mean a 'static' page? If that is what you mean, then I have tried to add a post to a regular page without success and I have also tried to change the home page back to a blog page and had problems there too. First, I can't add a blog to a 'regular' page. I thought maybe I could through Pagelines but it doesn't seem possible. Second, I tried to change my home page back to a blog page through Wordpresses framework by going to Settings> reading settings. There I changed my settings from 'A static page' to 'Your latest posts'. What this does is give me 2 pages; a Home page that is a static page and and index.php page that can be accessed by clicking on the banner. I want to re-link, re-establish or re-create index.php with my home page and am having trouble finding information on how to do that. Can anyone lead me in the right direction on how to do that? Thanks for your help thus far.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Technically, http://jamesroettger.com/wordpress/index.php is http://jamesroettger.com/wordpress/ (the home/static page). They're the same pages. The issue here is that for some reason, the latest posts aren't showing. I checked your site's code and the containers and DIV layers for the posts content are there, but they're completely empty. What are your current Template settings for the home page?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you for your help @catrina. I was able to solve this issue and this is how I did it. 1) Change Settings>Reading from 'A static page' to 'Your latest posts' 2) Go to Pages tab and delete your front page (it my case it's title was home) 3) Go to Appearance>Menus and delete your menu item that is associated with your front page in 4) Stay on Appearance>Menus locate the Custom Links box. Add a Custom link and label for the new front page. The URL for this custom link should be the top level of your site: mywordpresssite.com. Doing this has re-establised my front page with any posts that I make.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Brilliant!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0