Jump to content


Photo
- - - - -

Resizing The Feature Image


  • Please log in to reply
34 replies to this topic

#1 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 02 May 2012 - 05:19 PM

I currently have featured images (thumbnails) displaying on my blog at 150x150 for each post. I want to change that to 250x250...

Here's my .css (...but it's not working?!?)

.post-thumb {
margin-right: 0px;
margin-bottom: 0px;
}

.post-thumb .c_img {
width: 250px;
height: 250px;
background:transparent!important;
box-shadow:0 0 0!important;
border:0 none!important;
}



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 May 2012 - 06:20 PM

Rather than applying CSS, let's try going to Dashboard > Settings > Media and simply change the thumbnail size from 150px by 150px to 250px in each of the two boxes. The CSS is going to be overwritten by the settings. Might as well just change the settings.

#3 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 02 May 2012 - 08:17 PM

yea...I originally did that and nothing changed?!? I will say, that when I added that .css above..."space" for 250px in height was created (not width) - but the image remained 150x150. Strange?!?

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 02 May 2012 - 08:29 PM

Not strange at all. When you upload an image in WP, the image is copied by WP to predetermined sizes. Thumbs originally set at 150px by 150px will display as 150px square. Go to your post, select the original image, then set it to be the featured image again. That will resize it to the current settings from Dashboard > Settings > Media. Look for your posts images via the Media Library files attached to the post.

#5 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 02 May 2012 - 09:42 PM

hmmm....as with all html/css/etc that I touch...it doesn't seem to work. :-) I deleted the image and started over. I selected a template image sized 250x250...uploaded it to WordPress. I then went into the post and selected this image as a feature image. (I couldn't select any option to make it a thumbnail, medium size, etc....but I know it's a 250x250 image...so I clicked save.) Same results. I shows on the blog page as a 150x150 image.

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 03 May 2012 - 03:06 AM

In your WordPress settings, what is the default size set for thumbnail images?

#7 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 03 May 2012 - 04:17 AM

Settings >> Media >> Image Sizes : Thumbnail Size : 250 x 250

#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 03 May 2012 - 10:29 AM

Hi Rhelling, I think this may be a bug I'm not sure. Therefore, I will talk to one of the developers and see what he suggests.

#9 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 03 May 2012 - 01:54 PM

Thanks...let me know if you find something out.

#10 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 03 May 2012 - 05:14 PM

If you change the thumbnail size, you have to use a plugin to regenerate thumbnails in wordpress. Just search plugins for "regenerate thumbnails" and let it go to town. :)

#11 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 03 May 2012 - 07:02 PM

hmmmm....still not working?!?
(image still shows as 150x150 in the blog)

This is what my code says if I FireBug it:

Please Login or Register to see this Hidden Content


This is what I have in custom .css:

.post-thumb {
margin-right: 0px;
margin-bottom: 0px;
}

.post-thumb .c_img {
background:transparent!important;
box-shadow:0 0 0!important;
border:0 none!important;
}



#12 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 May 2012 - 02:09 AM

Please Login or Register to see this Hidden Content


^ I think that bit of code is the issue. It's being added there (I don't know how) and it could be reducing the size.

#13 Henry Perkins

Henry Perkins

    Friendly Contributor

  • Members

  • 198 posts
  • LocationAustin, TX
  • Country: Country Flag

Posted 04 May 2012 - 03:44 AM

I had similar issues with this in Pagelines and worked around it in plugins/pagelines-customize/functions.php and themes/pagelines/includes/class.posts.php

First in plugins/pagelines-customize/functions.php add the following code

Please Login or Register to see this Hidden Content


This will create a new image size thumbnail (250px by 250px) every time you upload a new image.

Then, in themes/pagelines/includes/class.posts.php modify line 180

Please Login or Register to see this Hidden Content

to

Please Login or Register to see this Hidden Content



#14 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 04 May 2012 - 03:46 AM

yeah, I was wondering about that. I tried to set my custom .css to [width=50%] but nothing changed. Any ideas on how I remove that?

#15 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 04 May 2012 - 03:47 AM

lol...(Henry) I practically posted the same time you did. Thanks....let me give that a try.

#16 Henry Perkins

Henry Perkins

    Friendly Contributor

  • Members

  • 198 posts
  • LocationAustin, TX
  • Country: Country Flag

Posted 04 May 2012 - 03:50 AM

My fix will only work for newly uploaded featured images. You will need to take simple_mama's advice and use a thumbnail regenerator if you want all your previous thumbnails to be given that extra 250/250 size.

#17 Danny

Danny

    Is Awesome!

  • Moderators
  • 16982 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 May 2012 - 09:15 AM

Hi Rhelling, Have you tried Henry's suggestion ?

#18 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 04 May 2012 - 02:37 PM

Nope. Didn't work. Something has to be up with this. It seems like this is a pretty simple issue. (I just want to show a larger thumbnail on my blog....pick a size, any size.) What gets me is when I go to set the "feature image" and select from the media library....I don't have an option to make that image a thumbnail, medium or large image. (Is that normal?) It just gives me one option: full size. Regardless...my 250x250 image is showing as a 150x150 image in the blog. To add insult to injury...I added the image in my post...and it shows as a 250x250 image. Lovely. lol Any more ideas?!?

#19 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 04 May 2012 - 04:38 PM

Yes, it is normal to not have an option to select the size for the feature image (this is a WordPress feature and WordPress doesn't provide that). If you add the image to your post, it provides settings for choosing the size. Did these options show up for you?

#20 Eileen Starbuck

Eileen Starbuck

    Super Member

  • Members
  • 125 posts
  • LocationOverland Park, KS

Posted 04 May 2012 - 06:54 PM

No. When I want to put an image in the post...I can't select any option other than "full size".