Jump to content


Photo
- - - - -

Submenu items not visible when hover BrandNav headmenu item


This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1 perininero

perininero

    Advanced Member

  • Members

  • 80 posts

Posted 01 May 2012 - 05:48 PM

At the test url

Please Login or Register to see this Hidden Content

we do not succeed in showing sub-menu items when hover headmenu/BrandNav; as seen on pagelines.com/store/ and hover menu item resources. F.e. the menu item "Social Media" has sub menu items. Pagelines settings are ok. Also tested with all plugins switched off. Seems like a setting display-block vs. display-none on the element style is wrong but we don't know how to fix this. Please note that the provided url is a test website, before launching redesign of a current website, hosted elsewhere. Thank you for your help.

#2 Henry Perkins

Henry Perkins

    Friendly Contributor

  • Members

  • 198 posts

Posted 01 May 2012 - 06:53 PM

In your Pagelines Header and Footer settings, do you have Enable Drop Down Navigation checked?

Also, if that is checked, make sure that the pages that will you want as sub menus are indented slightly in your menu options under Appearance on the left sidebar in your admin.

Please Login or Register to see this Hidden Content



In my example, Music, Interior Design, Business and Photography are drop down menu items.

EDIT: Also, you want to make sure that "Use Child Pages for Secondary Nav" is not checked, as this will create child pages in a separate menu and defeat the purpose of the drop down feature available in the Navbar.

#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 01 May 2012 - 07:41 PM

Henry's spot-on with this!

#4 perininero

perininero

    Advanced Member

  • Members

  • 80 posts

Posted 02 May 2012 - 08:06 AM

@henry thank you for your prompt reply. Unfortunately everything you mentioned seems to be ok. Regarding to your edit, also ok. This option is also mentioned at meta settings at a page, where you can "Select the menu you would like to use for your secondary nav"; tried both the brandnav and blank, because I got confused by this option at page level. When I check my page with firebug and the pagelines.com site with firebug, the only difference is, when hover, it shows/adds to the class of the main menu item (Resources) "sfHover" and adds to the css ul class sub-menu: "display:block;" instead of "display:none;" when you not hover the main menu item (Resources). I can't figure out which custom or framework css is conflicting. Seems like an extra setting css "superfish", which is loaded I think. Any other thoughts? Maybe I can try to build the menu's on the site like pagelines.com did to check this. Howto?

#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts

Posted 02 May 2012 - 09:14 AM

Hello, Can you do and provide the following please. ??? Provide screenshots of your: Header Template Menu Page (Menu page in Admin Dashboard) ??? Disable all active plug-ins and see if this resolves the issue. ??? Temporary remove all your custom CSS related to your navigation and see if the drop down menu is working then.

#6 perininero

perininero

    Advanced Member

  • Members

  • 80 posts

Posted 02 May 2012 - 04:06 PM

@danny thanks for your input. See

Please Login or Register to see this Hidden Content

and

Please Login or Register to see this Hidden Content

for the screenshots. All plugins were already disabled and this did not solve the issue. CSS also tried without custom rules. Thank you.

EDIT: and when previewing the standard Pagelines theme (admin/appearance/themes/manage themes..) at Preview, the sub-items show... This shows the settings are ok I guess.

#7 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts

Posted 02 May 2012 - 07:04 PM

Do you have these settings:

Please Login or Register to see this Hidden Content



#8 perininero

perininero

    Advanced Member

  • Members

  • 80 posts

Posted 03 May 2012 - 08:49 AM

@simple_mama Yes, these settings are ok. I just found a conflict with the Backstretch jquery I use for backgrounds. I deleted the code from the child footer.php and suddenly the sub menu items appear... :-) As I used Backstretch for many websites, I have to find another solution for the full screen background image which should change after every click. Any ideas? Thank you @simple_mama @danny @henry for your support on this issue.

#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts

Posted 03 May 2012 - 11:17 AM

Hi, I cant think of any plug-ins that would do a similar thing. I think the best course of action would be to contact the autor of the Backstretch and see what he recommends.

#10 perininero

perininero

    Advanced Member

  • Members

  • 80 posts

Posted 17 August 2012 - 12:43 PM

Status can be closed :-) thanks again