Jump to content


Photo
- - - - -

Orbit Theme - SubNav formatting errors


  • Please log in to reply
3 replies to this topic

#1 bkimberly2000

bkimberly2000

    Newbie

  • Members
  • 2 posts
  • Country: Country Flag

Posted 01 May 2012 - 04:18 PM

I'm having one issue with Orbit, and it's frustrating because I only have a very basic understanding of CSS. My main-nav uses submenus with the down arrows. On the home page, it works great, but when I am actually on one of the subpages from the menu, the formatting for the submenu is completely jacked. It appears that the submenu backgrounds take on the same transparency as the current page ancestor up top. That makes the text float over the page without any background at all. I presume this is not how it was supposed to be, but I am not good enough at CSS to know how to fix it. Here is the current style.CSS from Orbit... roughly line 195. ========== /*Main nav*/ .bc1, .cnt-comments a, #wp-calendar caption, input, textarea, .searchform .searchfield, .wp-caption, .commentlist .alt, #wp-calendar #today, .post-nav, .current_posts_info, .post-footer, .thecarousel, .success, .content-pagination a .cp-num, .hentry table .alternate td, .playpause, #page .wp-pagenavi a, .main-nav li:hover, .main-nav .current-page-ancestor a, .main-nav li.current-page-ancestor ul a, .sf-menu li li, .sf-menu li li li { background-color: transparent !important;} .main_nav .current-menu-item a { color: #fff !important;} ul.sf-shadow ul.sub-menu, ul.sf-shadow ul.children { background: transparent!important; } ========== Aside from the last entry that's missing a space before the !important, what do I need to do to fix this CSS so that submenus operate properly when on a submenu's page? I appreciate anyone's advice on this. Thanks! Brad Main site:

Please Login or Register to see this Hidden Content

Subpage:

Please Login or Register to see this Hidden Content



#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 01 May 2012 - 06:28 PM

Brad, Since you're using Orbit, a premium child theme, you should really visit and use the "Contact" button for support directly from the developer. Unfortunately, I do not have Orbit or access to it for testing, so your solution is the theme developer directly.

#3 pagelines13

pagelines13

    Newbie

  • Members
  • 1 posts

Posted 10 May 2012 - 01:00 AM

Brad i have the same problem, and you give me the answer:

bc1, .cnt-comments a, #wp-calendar caption, input, textarea, .searchform .searchfield, .wp-caption, .commentlist .alt, #wp-calendar #today, .post-nav, .current_posts_info, .post-footer, .thecarousel, .success, .content-pagination a .cp-num, .hentry table .alternate td, .playpause, #page .wp-pagenavi a, .main-nav li:hover, .main-nav .current-page-ancestor a, .main-nav li.current-page-ancestor ul a, .sf-menu li li, .sf-menu li li li { background-color: #YOURCOLOR !important;}

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 10 May 2012 - 02:35 AM

@pagelines13 Is that CSS code the solution you have for the problem or...?