• 0
Sign in to follow this  
Followers 0

Can't get a page to show up in the brandnav

Question

Posted · Report post

I've tried doing brandnav, or branding + navigation, even secondary nav, but I have a new page that simply won't show up in the header navigation. The page is here: http://kandemedia.com/portfolio/'>http://kandemedia.com/portfolio/ I tried download WP Super Cache (which wasn't on the site before) I also tried disabling all my plugins I tried moving one of my pages to "draft" to see if I could remove one page, instead of adding, but nothing in the brandnav or navigation on their own are working. I don't have any custom css It's for this site, and I'm happy to let you log in: http://kandemedia.com/ I'm concerned that I'll have to hit the "reset to default" pagelines option and have to go back. I asked this as a comment earlier and received no response. Help please?

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Are you currently using a Custom Menu (implemented in Appearance > Menus)?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Nope, standard... no changes whatsoever.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

What are your settings under Page Attributes for the Portfolio page?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The same as the other pages... (no parent), default and order = 7. Here's a screengrab: http://screencast.com/t/MjBkEPSn3

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

What happens if you try to use a Custom Menu? Is there a difference made?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I tried the custom nav code from this page: http://www.pagelines.com/forum/discussion/16775/trying-to-customize-navigation/p1 And it did nothing to 'publish' my portfolio page. It changed the color, though. Can someone from Pagelines please investigate? I've tried every suggestion. The one I haven't tried is going back a version in the framework when it was working, or resetting everything and starting over, which I'd really prefer not to do. Thank you.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well I bit the bullet and tried "restore to default" after exporting my settings, and that didn't bring the page "portfolio" to the nav. So next I tried removing the entire theme and going with a default wordpress theme. This worked... it brought "portfolio" into my nav. So then I reset the theme back to the pagelines framework and the link disappeared. So, it appears something in the code is either not recognizing the new page, limiting the number of pages that can show in the nav (which I doubt because I've tried eliminated several of the other published pages to test this and 'portfolio' still never showed up), or something else. Is this a bug? Is it new to this release? Can you duplicate it? Will you please log into my site and try? Anything would help please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Adding to this, so I tried renaming "expo-sure" to "expo-sure2" including the url. This worked. But then when I tried to change the status of that page to "draft" instead of "published" the page stayed. I literally can't get some of the pages to disappear from the nav. I'm assuming this is related.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

omg I finally found it. It's not in "pagelines --> settings" it's under "appearance --> menus" Sheesh.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Glad you found it but Catrina asked you about that much earlier. Menus are not created in PageLines, they're styled or applied. Creation is done as a WP function via Dashboard > Appearance > Menus.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

True... in re-reading her note, I thought she was asking if I had done a custom menu in the CSS (outside of pagelines). But it makes sense now. I kept looking in the pagelines templates and settings sections.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0