• 0
Sign in to follow this  
Followers 0

Featured images not showing up on blog index/pages

Question

Posted · Report post

I am trying to get images to show up on my blog index page. I believe this is done through setting a "featured image" on individual blog posts. My theme options are as follows: Under Theme Options --> "Post Thumbnail Placement" --> All blog/post pages is selected. Under Theme Options --> "Features on Blog/Posts Page" --> Show feature template on posts page is selected Under "Featured Image" on a post, when I try to set it, the image successfully uploads but when I click on "insert into Post" or "Save all Changes", the post itself doesn't show any changes and the image doesn't appear anywhere. However, under "featured image" under "Gallery", it shows the image.

1 person likes this

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

Hi Veronica! Yup you are correct it's set using the Featured Image. However, there is no "saving" or "inserting." I always found this rather strange so I can see how it can be confusing. So, when you click the text that says "use this as featured image," that's it. You don't even have to save the post or update it. Just close out the window and you should be good to go. Let us know if this works for you. Nick

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Veronica, Nick is spot on and yes it is confusing. I have accepted Nicks answer, should you require further assistance. Simply reply here.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry it's taken me so long to respond. As per the bottom of my original post, the problem is not that under the featured image "gallery" things don't show up, the problem is that the page itself doesn't reflect any of the images that successfully load, nor does the blog index page show any of the featured images. In other words, I understand how to set the featured image...the problem is that it doesn't properly do it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Veronica, I'm unclear why this is happening to the feature image/thumbnails. Could you go to Dashboard > Settings > Media and see if the box is checked for "When possible, embed the media content from a URL directly onto the page. For example: links to Flickr and YouTube." and that there's an image size set (default is 150px high and wide (same).

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just to be perfectly clear, are you following these steps to create a featured image on your blog post? [img]http://content.screencast.com/users/liveonshuffle/folders/Jing/media/51e6442e-a14e-4039-901b-0d2edc301b08/00000001.png[/img] Click that link. Then a box pops up to choose where to get your featured image from. [img]http://content.screencast.com/users/liveonshuffle/folders/Jing/media/48588c50-f070-4b7d-a4e1-c818e6580c30/00000002.png[/img] From there upload an image from your computer, and you will be taken to this screen once the image is finished uploading: [img]http://content.screencast.com/users/liveonshuffle/folders/Jing/media/96677ab8-a046-4db9-a90f-ebc10dd62eb1/00000003.png[/img] From here, you select "Use as Featured Image". Once you've done that, hit Save changes if you wish, and then click the X on the top right. You should see your featured imaging showing where you started from my first image in my post. [b]EDIT: Please make sure your wp-content/uploads folder is CHMOD'd to 777.[/b]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Henry, I changed my ftp folder permissions to 777 from 755 and that did the trick. Thank you so much! :D

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You're welcome! Let us know if you need any more assistance. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0