• 0
Sign in to follow this  
Followers 0

frame for individual widgets in same sidebar / widget-frame visible even if the widget is not shown

Question

Posted · Report post

Hi again, now that I achieved to add the border to my widget I realized another problem with that solution... The widget should not be shown on two pages, but on these pages I now see an empty frame, where the widget is supposed to be??¦ What do I have to do, to suppress this? Link: http://www.christianemohr.de/c.mohr_wp/kontakt/ And another problem: I wanted to use two separate boxes in the side column, but when I add another widget to the primary sidebar, than both widgets are wrapped in one border. Can I separate them somehow, or do I have to go for the secondary sidebar and then add the second widget in there? Thanks in advance Christiane

Share this post


Link to post
Share on other sites

12 answers to this question

  • 0

Posted · Report post

Hi Christiane, The reason for this is that your have added the CSS to the #sidebar-wrap this is why even though you have no active widgets the frame is still visible. What you will need to do is identify the specific ID or Class for the widgets. Check out my last post on your other topic as a example: http://www.pagelines.com/forum/discussion/comment/99694#Comment_99694 You simply need to do this for all widgets or add the CSS to the [code].widget-pad { <--- CSS goes here! ---> }[/code]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, this worked beautifully. I now have two separate widgets with a frame each. I tried to put a space between the two by changing the padding, but the padding seems just to affect the inner part of the widget. What is needed to separate the two widgets?Besides I wanted to decrease the space between headline and text inside the widget, but again me playing with the padding did not work out. It would be wonderful if you could help me here - thanks!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I just tried to visit your site and received an Internal Server Error.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ups, I redirected my domain to the folder, where the new website is located. When I check right after doing so, everything looked ok - now all of it is a mess??¦ I have to sort that out, supposedly even with my provider, I will come back to you with the correct link as soon as I'll have fixed the problem...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

ok, it seems to work again and the before mentioned links should work - sorry for the mix-up

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No problem. I'm happy it's working now.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

just to prevent a misunderstanding: my website can be reached again, but my problem regarding the widgets is still not fixed...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Have you visit PageLines -> Settings -> Website Setup and checked Remove Default Sidebars When Empty ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, this setting is set??¦ A short summary of what my problem actually is: 1) I want to add multiple widgets in the primary sidebar. Each widget should have it's own frame and the widgets should have a space between them. Current optics under http://www.christianemohr.de/c.mohr_wp/referenzen/ 2) inside the widget I would like to have less space between headline and text and text and bottom border I played with the paddings in the widget but achieved no effect...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

What CSS are you using to try to achieve what you're looking for?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

last I worked with #sidebar-wrap .textwidget { margin: 0.6em 0; } I tried a lot different selectors, that I got out of firebug. But in the end, none of it even made a difference in the widget text. About the space between the two widgets in my primary nav: For the moment I will just remove the second widget box as I don't need it right at the start, so I did not bother to fix that problem being as unsuccessful with the one that looked ways simpler to me ;-)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I found this with Firebug: [code]#sidebar-wrap .widget-pad { border: 2px solid #DDDDDD; box-shadow: 2px 2px 3px #CCCCCC; padding: 3px; }[/code] I changed it to:[code] #sidebar-wrap .widget-pad { border: 2px solid #DDDDDD; box-shadow: 2px 2px 3px #CCCCCC; margin: 0.6em 0; padding: 3px; }[/code] That put a distance above and below, so it should separate the text widgets.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0