• 0
Sign in to follow this  
Followers 0

Framework - secondary sidebar for jigoshop

Question

Posted · Report post

In the widgets section I have added various jigoshop widgets to the secondary sidebar and added in the template setup (hide by default), and set it to show on the shop page but it still doesn't show? My primary sidebar shows fine on http://hibbslupustrust.org/news but on the jigoshop page I only want the jigoshop widgets to show. I'm sure I'm doing something very obvious so I apologise in advance but would appreciate your help! Best wishes, John

Share this post


Link to post
Share on other sites

13 answers to this question

  • 0

Posted · Report post

Hi John, Would it be possible for you to reply and provide screenshots of your setup please. So I can try to recreate the issue.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Danny.... http://imageshack.us/photo/my-images/69/jh1i.png/ http://imageshack.us/photo/my-images/837/jh2.png/ http://imageshack.us/photo/my-images/809/jh3.png/ http://imageshack.us/photo/my-images/192/jh4s.png/ http://imageshack.us/photo/my-images/850/jh5.png/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am also unable to add a sub menu to the shop page? This appears ok for other jigoshop created pages such as http://www.hibbslupustrust.org/cart/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi @hibbsy78. You may want to use something like [url="http://wordpress.org/extend/plugins/widget-logic/"]Widget Logic[/url] if you only want certain widgets to appear on specific pages. If you don't use that, you can also do it by adding the widgets to your sidebars and then hiding widgets where appropriate (although this will be time-consuming and a pain in the rear). For the submenu, there are a couple pages that are dynamically generated so the submenu is set elsewhere. Visit PageLines -> Meta -> Product Archive and set the menu at the bottom.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok thank you... sub menu now active. I'll look at Widget Logic but at the moment I can't get my primary sidebar to show....?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok I think I'm up and running having amended the sidebar settings in the Meta menu. http://hibbslupustrust.org/shop

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It would be nice to remove the following text if anyone has an ideas... Home ??? Shop All Products So that at the top of my page starts 'Welcome to The Hibbs Lupus Trust online store!'

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

[code]body.jigoshop #breadcrumb { display: none; } body.jigoshop .page-title { display: none; }[/code] ...will get rid of the page title and breadcrumbs. Something else is going on with your site though that I can't figure out. When clicking around your store subnav going through all the links, then clicking back on the store menu, I am taken to the URL: http://www.hibbslupustrust.org/tweet/shop-online-and-raise-mon??¦-httpwww-hibbslupustrust-orgshop-online-raise-moneywt2-charity-hibbslupustrust-easyfundraising-lupus/ This, of course, is a 404 page. Do you have a social sharing plugin that may be causing a conflict? I can't even access your Store page now as it keeps redirecting me to that page. Just wanted to bring this to your attention.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Jenny....that code has done the trick! Can you try the store page again now..? I did change the slug from shop to store so that may have been the issue...it all seems ok when it try.. There does seem to be a slight error somewhere as when an item is added to the cart the confirmation message and option to view the cart doesn't appear. Thank you!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Does it work without super-cache?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Simon, Yes it appears to be working without supper-cache! Now I need to figure out how to exclude these pages!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

All better now. :)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

very helpful post thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0