Jump to content


Photo

BBPress Current Menu Page


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 thenbrent

thenbrent

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 02 July 2010 - 02:30 AM

Hi team, I'm using EcoPro & TerraForum. I have my bbpress installed in a forums directory, eg. example.com/forums/ and it's all working nicely except for the menu. I have created a menu item with the wp3.0 custom menu that points to example.com/forums, but when I'm on a forums page the "Forums" menu item is not selected. Any idea how to fix this? Thanks in advance.

#2 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 02 July 2010 - 05:00 PM

So the active state isn't working? You can assign a class to the body of the forums header. Then use that class to create an active state of that button when you're on that class? Does that make sense? If you provide a link I can help you out.

#3 thenbrent

thenbrent

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 03 July 2010 - 09:17 AM

The active state is working, if you mean the assignment of the current_page_parent class, but that class is being assigned to my blog index page, not the forums page.

I guess that's because the forum are outside of WordPress and therefore, WordPress defaults to the blog index page.

You can see what I mean at forums

It works fine for WP pages, eg. About and contact

#4 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 05 July 2010 - 05:00 PM

I understood what you meant. I was suggesting manually adding a class to the body of the forums pages so you can add the active state style