• 0
Sign in to follow this  
Followers 0

subfolder home going to "Direct Previewing of "Special Post Types" Not Available... Yet"

Question

Posted · Report post

Hello, I always place give my wordpress files it's own subfolder called something like /site. Then I pull the index.php and .htacess files into the root and point the index.php to the subfolder. I've never had a problem with this (on platform it worked fine). For the first time I have created a site in Pagelines. And now, whenever I type in http://earlymusicbesalu.com/site, it goes to this page: http://earlymusicbesalu.com/?feature=site-header-feature Why is this happening? I need to get this fixed because for some reason, our pages in google search are showing as earlymusicbesalu.com/site/contact, etc. I have tried resetting the permalinks, the .htaccess files, I've installed All-in-One SEO to see if it was a canonical URL issue, but I don't know what else to do. Thanks.

Share this post


Link to post
Share on other sites

25 answers to this question

  • 0

Posted · Report post

Thanks so much for keeping at this with me! When I create a wordpress site, I like to keep the files in it's own folder and then copy the index.php and .htaccess to the root folder to point to it. I follow the instructions here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory. I've created about 15 or more sites this way, and never had this problem. I've posted a screenshot of the [url=http://www.earlymusicbesalu.com/emb-site-folder.jpg] /site folder[/url] here. I did disable the feature slider and yes, problem still persists. :(

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You are using a feature called "site-header-feature". In the wp settings under permalinks this option enabled: Post name: http://wp10987297.wp224.webpack.hosteurope.de/wordpress/sample-post/ It tries to resolve your adress, like it does with other adresses as well, and the closest it finds is the feature named "site-...." Try changing the WP options, and the feature name.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the input @gyoery! Let us know how this works out for you @antonella.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the tip. However, I can't find where this option is. Can someone please guide me through it? Is it in the Pagelines dashboard, settings? Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes. It's a WordPress default setting on the left of your Dashboard: Settings > Permalinks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I still don't understand this. I don't see anything about the site-header-feature. I have the custom structure set up as /%postname%/ but it keeps getting saved as just /%postname%/. I've tried setting to other types (for example, month/name) but I'm still getting the same errors. What am I supposed to be looking for exactly?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

This is also weird because I haven't done anything different from my other sites (that I'm aware of) so I don't understand why it's not working on this one in particular.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Do you have WordPress installed in your base html folder (something like public_html or htdocs)? The page it's resolving to is evidently a Special Post Type and thus I'm thinking it's trying to view a slide as @gyoery pointed out earlier. Check your plugins and also check the content of your slides to see if they have any links in them in the /site feature sliders. Some servers require that you CHMOD .htaccess to 777 in order to make it writeable. I'd suggest you FTP to the /site folder, CHMOD that to 777, then update your permalinks [u]without changing anything[/u]. Then, check to see if it worked. CHMOD the file back to 755. If it doesn't work, it may be due to an error in wp-options or wp-config. I suspect though, the updating of permalinks with the .htaccess file writeable should work.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

that would have been my second guess, that wordpress (localhost) does not have permission to view the content of your .htaccess protected folder, and thus is acting this way. I had the same problem, but without .htaccess Though my link was wrong, and that's why the information got resolved badly. Also you could try changing the depth to file/file/ to avoid conflicts. 1. Make sure all your links are indeed correct. 2. Try without .htaccess 3. Try changing depth and maybe name 4. If all fails, check again if your file folder is really located in www/wordpress/file If still nothing, post back, and I'm sure the guys will have a screensharing or something like that...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@gyoery Thanks for your additional insight.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

thanks for all your input. It helped pinpoint and clean up stuff, but I'm still getting the error. This is what I've done. 1) renamed the feature image 2) deleted the feature set I had that was site-header-feature as I wasn't using it anyway 3) went through all the links and made sure they weren't pointing to /site/etc. 4) deleted the .htaccess file and recreated them 5) tried changing the chmod on the /site folder to 777, but then I couldn't get into the admin and reset the permalinks. Set it back to 755. 6) reset the permalinks. The only area I see a problem is here: I am using WPML translation management. In the String translation there is the widget for my actual language menu found at the top of the site (English Espa?┬▒ol) which is basically a text widget in the Universal sidebar. This has the correct links. But then there's another text widget which I had created at some point and these have the bad links. However, I no longer have such a text widget anywhere -- neither in the sidebars nor in the inactive widgets. I can't find it anywhere to flush it out. This may be causing the problem. Is there anywhere I can get rid of old widgets that are hidden?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Strange. Where are you seeing this other text widget (with the bad links) on your site if it's not in the sidebar or inactive widgets area?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm seeing it in the String Translations section of WPML. [url=http://www.earlymusicbesalu.com/StringTranslation.png]See screenshot.[/url]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

you should be able to manage how google displays your site within google dev. Can you please post a scr from your file structure in the wordpress folder maybe from ur SFTP connection?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Since this is a plugin-related issue, it would be a good idea to look into WPML support. Have you already tried looking into the WPML forum to see if anyone else has had this kind of issue before?: http://wpml.org/forums/forum/english-support/? If there is any insight about the issue in the String Translations section, that may shed light on the error you're getting.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I dont think it is a pugin issue... have u tried disabling it?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I do have a support issue logged in at WPML forum already. However, I did disable the plugin and the problem still exists. I've uploaded a screenshot of the [url=http://www.earlymusicbesalu.com/emb-file-structure.jpg]file structure here[/url]. Thanks.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

What happens when you disable the feature slider? Does the problem persist?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

so u actually moved your wordpress install within the folder site? I thought it was the other way round. Would be nice to see the next depth as well. But anyways, I think, your wordpress is in the site file, and your index.php redirects the user to that site? So you are actually already in the site folder when using wordpress, and unless you have another site folder in the wordpress folder (where wp-admin, etc is) then obviously you cannot find it. Maybe I am wrong, but please post the next depth of filestructure, so I can make sure.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yes... that wont help you... try creating a site folder with an index.html inside your site folder... basically when some1 visits your page, he already is in that folder! http://earlymusicbesalu.com = http://[your RDNS IP]/site so http://earlymusicbesalu.com/site = http://[your RDNS IP]/site/site And since you do not have that folder, it tries to resolve it as good as it can, and gives you the closest thing it can find. PS: Basically all you did is rename the wordpress folder into site.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Antonella, I just read what you wrote above about how you like to copy .htaccess and index.php from a WP install to your root folder. That doesn't work properly and will invariably cause serious errors. There's absolutely nothing wrong with having multiple WP installations in folders on your site. I have a dozen or so. HOWEVER, you also need to have a basic, simple one in your root, as I do, with little more than menu items and a similar appearance. You only need one static page for a home page. I'm unsure where and how you found the information that guided you to create folder based WP installs then copy those files but it's a disaster waiting to happen, in my opinion. Clearly, it seems your site has one or more links somewhere that are guiding the site to look in the root, then not finding what the link expects, it's defaulting to essentially, a 404 error for feature slides (special post types). You need to follow instructions we provide (you changed what I had written earlier by deleting .htaccess, when I told you to CHMOD that file only) and you CHMODed the folder to 777 when no such suggestion was made.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Rangelone, Thanks for your input. Sometime ago I came across that instructions page in the codex (link posted above) and it said this: [quote]Many people want WordPress to power their site's root (e.g. http://example.com) but they don't want all of the WordPress files cluttering up their root directory. WordPress allows you to install it into a subdirectory, but have your blog exist in the site root. [/quote] That is why I have been setting up all the wp files and folders in it's own subdirectory, but then having an index in the root so that the domain name www.example.com alone will find it. Is this not okay to do then? I checked my other sites and I realized that when we enter the domain www.example.com/site it is supposed to go to a 404 page. What through me off with this particular site is that it is bringing up that weird message "Direct Previewing of "Special Post Types" Not Available... Yet". Also, I didn't understand why on google pages were showing up with www.example.com/site/page. On some sites I don't want all the wp folders and files cluttering up the root because I have other sites folders from other sites and projects there too. Thanks. Antonella

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If your question is answered please close the thread by accepting an answer.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I agree with what rangelone is saying about moving your htaccess and index.php files around in the way you described. If you avoid doing this, you can check your site again to see if your problem persists.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am having the exact same problem. I created everything inside the subfolder while the site was in development and once it was ready to launch I pulled the index.php and .htaccess to change the site over and the whole website went crazy. first all the links broke so i tried to update the permalinks and still nothing. i was going to just re-upload all new images because I couldn't get the old ones to work when I couldn't even get the dms editor to show up on the screen. At this point I have backed up and uninstalled the old site and now I'm having problems trying to restore everything like all the custom css that went into the site. Where is all the custom css for the pages stored in ftp? The site was supposed to launch today, I have never had this problem before and I have a pissed off business owner at me. It looks like I'm pulling an all nighter re-building this site unless someone can help :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0