• 0
Sign in to follow this  
Followers 0

Views Plugins

Question

Posted · Report post

Is anyone using the Views plugins successfully with PageLines framework? I can't get the Views plugin to hook into the "single" or "archive" pages for my custom post types. Apparently Views uses the_content() hook to insert it's content (if that helps).

Share this post


Link to post
Share on other sites

32 answers to this question

  • 0

Posted · Report post

Hi, Can you post a link to this plug-in please.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yup. You can find it here: [url="http://wp-types.com"]Types and Views[/url].

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Under settings add [b]post_content[/b] in the theme support box.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Simon but can you clarify? I went to the PageLines settings and went through all the tabs trying to find something in reference to post_content but to no avail. I then looked at the settings in the View plug-in but didn't find anything there either.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hm, I looked around the settings, too, but I'm not certain what @Simon is referring to either (I searched for settings pertaining to "theme support"). Maybe he meant inserting the hook into the functions.php file.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

http://screencast.com/t/Z15FUswYNEG

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Wow. Bizzarre. I don't have that available on my options screen: [img]http://farm8.staticflickr.com/7100/7011647033_4a5cd1c998.jpg[/img]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I downloaded the beta, maybe thats the problem..

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I think they only have BETA right now. I'm using version 0.9.4.2, what version do you have?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, I think they do only have beta now: http://wp-types.com/2011/11/types-and-views-launching-in-beta/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes they do ... they ONLY have a beta. :^)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hm, I wonder why your options are different. I looked around the plugin site and they don't have a support forum of any kind available (was hoping I could search around and see if anyone else using the plugin had the same problem). Have you already tried deactivating your other active plugins?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

They do have a support forum but it's a bit hidden. I've posted a question to them. They're usually pretty good at getting back but it's not 100% ... we'll see. I'll also do some more searches there. If you're interested the "support" button gets you to the discussion forum. It's possible this is only for paying customers.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ah, okay, I totally missed that! You're probably right since I'm not a paying customer. I think it's best that you reach out to them and hopefully they'll provide some helpful insight that can be shared here.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I will definitely share anything I get.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

http://screencast.com/t/FhCsIWTQ

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I can't find that page even using google. Can you send me the URL?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

nevermind. i found it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thats the account page here http://wp-types.com/

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Simon, I know I accepted this answer but I have a problem. I have 0.9.5.3b3 now and the option you mentioned is now an option but changing it still doesn't work. Did it work for you?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes it did gimme a min i want to check something.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yea seems to work in 2.1.3, I was using dev branch before.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

So just to check ... you create a View Template ([url="http://flic.kr/p/bFC5in"]http://flic.kr/p/bFC5in[/url]) and then associate it to either a Single page or an Archive and when you go to that page the View is displayed ([url="http://www.flickr.com/photos/14261777@N00/6865842354/"]http://www.flickr.com/photos/14261777@N00/6865842354/[/url]? I'm using PageLines 2.1.3 too but it just produces a normal blog page at that location. In my example the CPT is workouts so going to WEBSITE/workouts looks like this: [url="http://www.flickr.com/photos/14261777@N00/7011966463/"]http://www.flickr.com/photos/14261777@N00/7011966463/[/url]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well, all i did, after spending $50 is create a new CPT with the types thing, then add a new views template, assign the template to the cpt, then view the post type page and saw my template text there. Thats what it supposed to do isnt it?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well you'd get the basic title and body of the text even without Views. What Views would allow for is all sorts of reformatting and the display of custom fields that you've defined. I am really impressed with what these guys are doing with these plugins and now that Gravity Forms is backing them and building in support you can put some pretty forms on top of this very easily. Anyway, I'd guess that you're probably having the same problem as me. Bummer. BTW, how did you come to the name of post_content for the function? Is that just your intimate knowledge of Pagelines or did the debugging feature they talk about work for you (it doesn't for me).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0