• 0
Sign in to follow this  
Followers 0

How to integrate forums with bbpress?

Question

Posted · Report post

From what I have found, bbpress integrates itself into the WP forum. I have several topics listed out in the "Forums" part found in the WP admin panel. When I click on forums on my site, the site tells me that I do not have any topics. How does bbpress and buddypress integrate with the sites existing forums? How do I get my forum topics to show up? This may be a problem I created for myself when I was trying to figure out how to integrate bbpress before Pagelines release the fix for bbpress. Any assistance is greatly appreciated.

Share this post


Link to post
Share on other sites

20 answers to this question

  • 0

Posted · Report post

Have you checked out this support topic? http://www.pagelines.com/wiki/How_to_Use_the_bbPress_for_PageLines_Plugin

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the link simple_mama. I have seen those. They were helpful for the initial install, however they do not provide any documentation on how to actually get it working other than, "That's it! bbPress will now be compatible with the PageLines Framework." What does compatibility look like? How would I use bbpress within the pagelines framework? I have already scoured the bbpress forums with little luck. Thanks for your time.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi, Please follow the instructions below. Install bbPress Install PageLines bbPress integration plug-in Then go to Wordpress Admin Dashboard > Forum and create your forums. Once this is completed you, simply view the forum by clicking on the View Page. If you haven't made any changes to the settings, simply add /forums/ to the end of your website URL and it should take you to your forums. I recommend you read through the bbPress documentation. ALso you can customise the layout of your bbPress forum by going to Wordpress Admin Dashboard > PageLines > Meta and you should have a 4 bbPress templates to customise.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Danny, Thank you, Thank you, Thank you! First time I have seen my forums actually appear on my website!!. Typing /forums/ did the trick. The only issue I ran into is that my forum page menu button does not link to this /forums/ location. When I changed the permalink in WP admin>pages>edit permalink to "forums" (changed from "forum", saved it, and reloaded, it would send me to the /forums/ location, however the forums were blank again. Any ideas? I have tried to add different "slug" words into the body section of the "forums" page, but have not had any luck. I have read everything I could read at http://bbpress.org/documentation/ which redirected me to http://codex.bbpress.org/. I was not able to find very much useful information, and most of it was above my skill level. Is there an additional documentation page you would recommend? Thanks again for taking the time to write your initial response out in a language I could understand. I really appreciate it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello, Would it be possible to provide a link to your website please, so I can see this first hand.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hey Danny, My site is c@h@a@n@g@s@h@a@h@u@a@.@c@o@m@ Take out the @ I thought I had found a fix for this by changing the "permalink" on the "forums" page. However, there is no communication going on between BuddyPress and the forum. When you go to the profile page and look at your info, it does not recognize any posts you have made or replied to. It also does not follow rules for posting (the first post of each person must be Ok'ed, then they will be able to freely post afterwards) Thanks again for your help. There is no way I would figure this out without it.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi, I am unable to see the issue, is this now resolved? If not, I recommend you contact BuddyPress/bbPress support.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the try Danny. I'll post anything I find out.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, here's what I found in the Buddypress forums regarding integration of buddypress and bbpress forums: Apparently the forum tab and forum activity on the activity feed are disabled because of lack of support for BBpress 2.0 plugin. The Buddypress team is working to include this fuction on 1.6 and the beta should be out in the next few weeks as of this post date.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for looking into this, @highreach!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, I have done some more research into my forum issues. It turns out that the lack of communication between forums and buddypress on my site goes much deeper than it should . What I did: I made a custom menu item called "forums" and which made my forum www.mysite/forums. The problem: When I click on it it takes me to www.mysite/forums. (all seems good) Then, when I click on any of the topics, it takes me to www.mysite/forums/forums/topic-title My gut is telling me that the extra "forums" is causing problems and I can't find anywhere here or on buddypress forums if this is what is causing the problem, but any input would be greatly appreciated. Thanks

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi, This is a issue you really need to ask the bPress support team, this isn't an issue with PageLines product(s).

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Will do Thanks for the advice! If any passerbys happen to have any ideas, I'm all ears!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Please let us know what you find out too. We'd love to hear what they have to say!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Has anyone had any luck figuring this out?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Highreach, there is a conflict created by the word forum or forums, depending how you have BuddyPress set up with bbPress. First, I installed it in a folder called "discussion" instead and don't use the word "forums" or "forum" in the menu. Another option is "community". In Dashboard > Settings > Forums you'll find Archive Slugs. Change the word of the Forums base from forum to something else (community, discussion or anything you prefer). That's the conflict between bbPress and BuddyPress. It should resolve issues you're experiencing. You may need to update your permalinks (without changing them) by simply saving.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hey rangelone, Thanks for taking a crack at it. After I followed your idea to the best of my ability (not sure what "installed it in a folder called discussions" means), I still ended up with my original problem When I click on Dashboard>forum topics, I have a list of all of my forums. After changing the menu item to discussions, changing the archive slug to "discussions" and making sure the permalink is called "discussions", I am able to access a forum area, just not my forum area. It is blank and contains none of the discussion that is contained in the forum I am trying to link. Even though this didn't work, I really appreciate you taking the time to try and help. Thank you.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Highreach, I think the issue may be related to how you have created your forums. Can you reply and inform us how you have created your forum i.e. what is the structure which are forums and which are categories. Also, did you ever contact bbPress support for assistance?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm not sure of the best way to explain my forums. Here is the link: http://changshahua.com/forums/ I am on the bbpress forums, but I have not had an answer yet.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

How did you set up the forums (for example, the first one you created)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0