Jump to content


Photo
- - - - -

Events Manager conflicts with contentbox


  • Please log in to reply
9 replies to this topic

#1 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 12:45 PM

Hi

I am using the Event Manager plugin for event management. It works allright for me, except I cannot use content boxes on event pages because they repeat the entire event information within the content box. As soon as I type anything into the content box, it repeats the entire event information.

You can see an example

Please Login or Register to see this Hidden Content



#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 29 February 2012 - 12:55 PM

Contentbox uses the_content filters before rendering its output, the events plugin is adding its content using that filter, thats why your seeing double. All i can suggest is make your own special copy of contentbox, rename it in the section.php and remove the filter by changing this line:

Please Login or Register to see this Hidden Content

into

Please Login or Register to see this Hidden Content



#3 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 01:04 PM

Hi pross How do I "make my own special copy" of contentbox? Is this a section ? so I have to register a new section based on the renamed contentbox file ? Thanks

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 29 February 2012 - 01:11 PM

No you dont have to register anything! Just go into pagelines-sections folder and copy contentbox to contentbox_2 no open contentbox_2/section.php and change the header like so:

Please Login or Register to see this Hidden Content


And make the edit i said before to remove the filter.

Now click the refresh store button and there will be a second contentbox section!

#5 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 01:29 PM

Ok I copied the new section, named it contentbox_2, changed header, changed $c = $content;, saved, refreshed (its in the store!), activated on sidebar2, filled some content into contentbox_2. It isn't saving, the box stays empty.

#6 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 01:34 PM

Oh, and its doubling the contentbox on other pages

#7 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 02:18 PM

In fact, the doubling is loading the contents of the original contentbox

#8 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 02:19 PM

should I deactivate the original contentbox ?

#9 zvelena

zvelena

    Advanced Member

  • Members
  • 74 posts

Posted 29 February 2012 - 04:29 PM

OK I deactivated the original contentbox and now its working allright. Thanks pross ! Elena

#10 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 02 March 2012 - 02:15 PM

Glad you were able to figure this out Elena! :)