Jump to content


Photo
- - - - -

Navigation Hover/Current Background Color & Twitter Question


  • Please log in to reply
16 replies to this topic

#1 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 14 February 2012 - 04:06 PM

I am building on MAMP so I cant give an URL. I am trying to change the background light grey color on the navigation, in this case I am using the brand nav. I have tried adding this to my child theme: #brandnav ul li a:hover { background: none; } But it does not work...I can change the color but not remove it, I have also tried transparent with no luck? Another thing is at one point in the pagelines back end I could add a twitter bar that ran across the bottom of the page, I cant seem to find it anymore!? Thanks in advance

#2 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 14 February 2012 - 04:30 PM

A CSS plugin for the menu will be released to the store soon. Just waiting for it to be approved. This will easily solve your menu CSS issues. The twitter bar is there. You need to add it in the Templates settings.

#3 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 14 February 2012 - 05:07 PM

I am seeing the standard twitter box, but not the bar? Strange. Any idea when this will be released, and in the meantime any easy way to fix my problem?

#4 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 14 February 2012 - 05:20 PM

Can you give a screenshot of the twitter issue? The Store plugin is coming soon.. trust me, I'm as anxious as you. Let me know what exactly you need changed. BG color on normal state or hover? PS background: none isn't a color. ;) You need to use transparent instead.

#5 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 14 February 2012 - 07:28 PM

BG state on both hover and current. I have tried using transparent but it did not work.

#6 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 14 February 2012 - 08:49 PM

Also the twitter bar is not even showing up in my templates section.

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 15 February 2012 - 03:20 AM

Which templates section are you looking at?

#8 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 15 February 2012 - 04:02 PM

Arg, I see its in the morefoot section! Ok now how about that menu issue?! Thanks.

#9 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 15 February 2012 - 08:42 PM

Sorry to elaborate id love to remove the grey background on the current/hover status on the navigation, cant seem to get it away, I have tried transparent as I said above. Anyone? Thanks.

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 16 February 2012 - 03:53 AM

Try this code:

Please Login or Register to see this Hidden Content



#11 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 16 February 2012 - 04:49 PM

Nope :(

#12 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 16 February 2012 - 05:39 PM

I have figured out the CURRENT page fix:

Please Login or Register to see this Hidden Content


I have yet to figure out the HOVER, if anyone could help that would be great.

#13 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 17 February 2012 - 04:22 AM

Try this one:

Please Login or Register to see this Hidden Content



#14 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 17 February 2012 - 05:41 AM

Sorry, no I have tried all the obvious combinations like this. I was hoping or at least imagined someone would know the answer to this fairly basic question as I hope it has been done before?!

#15 5344

5344

    Advanced Member

  • Members
  • 58 posts
  • Framework Version:latest
  • Country: Country Flag

Posted 17 February 2012 - 06:10 AM

Solved it.

To remove hover bg color:

Please Login or Register to see this Hidden Content


To remove current item bg color:

Please Login or Register to see this Hidden Content


I have put in a suggestion below to lay out the nav styling better as right now its not even even set or user friendly to edit at all.

Please Login or Register to see this Hidden Content



#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 February 2012 - 06:42 AM

The navigation classes are all defined by wordpress internally all the framework does is wrap a div around it #brandnav etc. Here are some of the classes used by wordpress:

Please Login or Register to see this Hidden Content



#17 webgirl2013

webgirl2013

    Newbie

  • Members
  • 7 posts
  • Country: Country Flag

Posted 12 July 2012 - 05:23 AM

I have been trying to do the same ALL DAY @-) , reading lots of forum posts and finally found this to work, amending the fix shown above:

Please Login or Register to see this Hidden Content


Hope this saves someone time. Shame the hover background color for the main menu comes as standard with the template. It should be something you have to add, not remove.
:-/