Jump to content


Photo

Mis-alignment of Social icons due to change post Title Length


  • Please log in to reply
26 replies to this topic

#21 manojgupta26

manojgupta26

    Super Member

  • Members
  • 144 posts
  • Country: Country Flag

Posted 13 February 2012 - 03:51 PM

Hello Simon/Pagelines Support? Is anyone looking into the issue: The Like button is scrolling with redundant text....How to get rid of it? Also..I Would be really thankful if you can suggest me the right div code for top padding, Simon suggested me..

#22 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 February 2012 - 04:02 PM

Maybe the code you originally used for facebook is wrong, i only copied your original code. As for the padding, you have a class dont you? .buttons-home add a margin to that.

#23 manojgupta26

manojgupta26

    Super Member

  • Members
  • 144 posts
  • Country: Country Flag

Posted 13 February 2012 - 05:13 PM

Simon,

I originally provided this code

 <iframe src="http://www.facebook.com/plugins/like.php?href=<?php echo urlencode(get_permalink($post->ID)); ?>&layout=button_count&show_faces=false&width=90& action=like&colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:90px; height:20px;"></iframe>

But you have provided

 <iframe src="http://www.facebook.com/plugins/like.php?href=%1$s&amp;layout=button_count&amp;show_faces=false&amp;width=90&amp; action=like&colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:90px; height:20px;"></iframe>

There is a slight difference between the two..

My coded uses -
 <?php echo urlencode(get_permalink($post->ID)); ?>&

and you have replaced it with ->
 %1$s&amp;

If I paste my original code, it doesn't work anymore...?

Any suggestion would be of great help!

Regards
MG

#24 manojgupta26

manojgupta26

    Super Member

  • Members
  • 144 posts
  • Country: Country Flag

Posted 13 February 2012 - 06:03 PM

Also the frames of different posts have stick together...

#25 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 13 February 2012 - 07:38 PM

 <iframe src="http://www.facebook.com/plugins/like.php?href=%1$s&layout=button_count&show_faces=false&width=90&action=like&colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:90px; height:20px;"></iframe>

Sorry, its the forum software adding ampersands everywhere....

http://pastie.org/3375733

#26 manojgupta26

manojgupta26

    Super Member

  • Members
  • 144 posts
  • Country: Country Flag

Posted 14 February 2012 - 04:18 AM

Simon, It worked like a charm :D Thanks! But now the frames of different posts have stick together...:(

#27 manojgupta26

manojgupta26

    Super Member

  • Members
  • 144 posts
  • Country: Country Flag

Posted 14 February 2012 - 08:05 AM

It's Done!! Thanks Simon for your excellent support!