Jump to content


Photo
- - - - -

Challenge with Feature Background Image scaling


  • Please log in to reply
28 replies to this topic

#1 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 06 February 2012 - 11:11 PM

I am trying to use an image as a Feature Background Image. However, no matter what scale I upload the image, the Framework seems to be scaling it up so part of the image is cutoff. I am using an image at 960x330 which can be seen on the 5th tab here:

Please Login or Register to see this Hidden Content

You can see that a portion of the "i" is cutoff. How do I make the background image fit into the displayed area? Thanks! Sterling

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 February 2012 - 11:43 PM

Sterling, as I'm seeing it, the image itself is 900px by 300px. You need a graphics editor to resize the image to 960px by 330px and should have it in the feature images background. At present, it appears to be in the feature image field.

#3 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 08 February 2012 - 09:02 PM

Please look at tab 5 and not tab 1

#4 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 08 February 2012 - 09:03 PM

Why does it increase the size such that the full image is not viewable on the screen?

#5 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 09 February 2012 - 04:09 AM

I'm not sure, but probably because of CSS. Do you mind using some kind of CSS tweak to move the image down?

#6 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 09 February 2012 - 07:32 PM

I am not opposed to using a css tweak. Before I do that I would like to understand the default Pagelines operation. What is it doing to images I set as the background image in a feature? Why does it expand the image so it is no longer fully viewable? What rules is it using to expand, height, width?

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 10 February 2012 - 03:37 AM

I checked the CSS for the image in your fifth slide but there is none that is resizing the image to be larger and the image isn't being enlarged after upload either. I'm not sure what could be causing this. Have you tried uploading an image that is smaller than 960px-wide in a different slide to see if the problem persists?

#8 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 10 February 2012 - 07:28 PM

I just added a new 6th slide with an image that was 900px wide and it is doing the same thing. It seems to only occur when the image is a background image. What are the rules that cause the background image to scale on features?

#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 10 February 2012 - 09:37 PM

I'm sending you a Private Message via the Inbox at the top of this page.

#10 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 13 February 2012 - 07:41 PM

Thanks! Got it

#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 15848 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 14 February 2012 - 09:18 AM

Hi, Is this issue now resolved ?

#12 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 14 February 2012 - 11:23 PM

Sorry no it is not resolved. I have adjusted which two features it is now 4 and 5. But I still have the issue. I tried the recommended size to 960 x330 and it still does the same thing with the background image.

#13 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 15 February 2012 - 03:46 AM

I'm including this issue in a report to send since it's re-occurring. I'm not certain what could be causing this! :

#14 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 15 February 2012 - 10:26 PM

Is there someplace where it lists the default ideal picture size for the different feature styles (background, text on bottom, text on side)?

#15 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 16 February 2012 - 04:03 AM

It is supposed to be 960px regardless of where the text is placed.

#16 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 16 February 2012 - 06:09 PM

Even for the "text on the side" options? It seems like you would want it shorter there? What about height?

#17 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 17 February 2012 - 04:29 AM

The text on the side options is an opaque overlay over the image, so the image is still seen behind the background color (as shown in the feature slider here:

Please Login or Register to see this Hidden Content

). The ideal height should be around 340px.

#18 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 18 February 2012 - 07:06 PM

It looks like the height for the background style feature image is 380 and it scales up to fit the height and lets the extra image just be cut off. This looks like the default behavior, can someone confirm?

#19 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 18 February 2012 - 07:18 PM

Usually the image shouldn't scale up. The top margin of it should align with the top of the slider.

#20 sterlingbates

sterlingbates

    Advanced Member

  • Members

  • 30 posts
  • Country: Country Flag

Posted 18 February 2012 - 08:25 PM

I have a pretty default installation and it seems to be scaling up. It also depends on if you are using Feature-Background or Feature-Media images. The Feature-Background scales up The Feature-Media does NOT scale up