Jump to content


Photo
- - - - -

Buddypress register page missing


  • Please log in to reply
3 replies to this topic

#1 ilkka

ilkka

    Advanced Member

  • Members
  • 34 posts
  • Country: Country Flag

Posted 01 February 2012 - 11:06 AM

Hi, Installed Buddypress with 2.1 update and almost everything works fine. My problem is that I don't get the usual login box for "register" page. When I try to open "register" page, the front page is shown without the login/register box. I am using a static frontpage and fullwidth template on the front page.

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 15215 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 01 February 2012 - 12:28 PM

Hi, Can you post a link to your site please, so we can take a closer look.

#3 Jackey

Jackey

    Advocate

  • Members


  • 685 posts
  • LocationHelmond
  • Country: Country Flag

Posted 01 February 2012 - 12:36 PM

Do you have wordpress installed in a subfolder on your website?

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 01 February 2012 - 07:19 PM

If you're logged in as admin or a user and try to go to register, Wordpress and Buddypress see you as already registered and to prevent you from doing harm to your account or yourself, they redirect you to the front page. Try logging out entirely, then clicking the register link and you'll see it. This is a long-term issue many have had but it's there for a valid reason.