Jump to content


Photo
- - - - -

Sidebars not showing


  • Please log in to reply
4 replies to this topic

#1 owi_dv

owi_dv

    Member

  • Members
  • 27 posts
  • Framework Version:V2.4.1
  • Country: Country Flag

Posted 31 January 2012 - 04:25 PM

So I know this must be elementary to you all, but I'm finding it impossible to display the primary and secondary sidebars. I've dragged them into the SB1 and SB2 areas in the template setup (making sure they aren't hidden by default). Then I've dragged a couple of custom menus to the primary and secondary sidebars on the widget setup (and saved). The sidebars do appear as expected on my default page, but not other types (box, feature, etc.). What am I missing? The draft website is at:

Please Login or Register to see this Hidden Content

Dave

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 31 January 2012 - 07:25 PM

Dave, go to Dashboard > PageLines > Templates and click on Content Area (on the right side graphic display. A list of pages will appear. Pick each page template where you're not seeing the sidebars and then click the sidebar in the graphic. Make sure the Primary and Secondary are installed in their proper slots for each page.

#3 owi_dv

owi_dv

    Member

  • Members
  • 27 posts
  • Framework Version:V2.4.1
  • Country: Country Flag

Posted 31 January 2012 - 08:13 PM

I still must be missing something. I follow your directions and click on Content Area, then I select one of the page templates, then click on SB1 in the graphic. But as soon as I click the graphic, I get the message below saying I'm editing> Sidebar 1 [Global Scope]. This has got me really confused because I thought I was just making changes to one of the page templates! Anyway, it's still not showing the sidebars on anything but the default page. I have gone to each of the individual pages>page setup to confirm that the primary and secondary are indeed placed SB1 and SB2 of the Content Area.

#4 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 31 January 2012 - 10:53 PM

Do you have the full-width page set as default in Pagelines -> settings -> Layout Editor -> default Layout mode? You can also set the layout mode to 'right sidebar' in the individual page meta settings.

#5 owi_dv

owi_dv

    Member

  • Members
  • 27 posts
  • Framework Version:V2.4.1
  • Country: Country Flag

Posted 01 February 2012 - 10:58 PM

Well, I continue to have problems with sidebars on some pages. For instance, Nothing is showing in the SB1 area on box pages. I've confirmed that the primary sidebar is active is the SB1 template area (double checked its not hidden by default. In the layout editor, I have the default layout set as having one sidebar in the right. I am still not sure I understand the advice from rangealone yesterday. In template setup--do each of the page type templates really need sidebars set up individually? Because it sure seems that sidebar areas are global settings. Nevertheless, I've got a sidebar on my default page layout and I can't seem to show a sidebar on a box page if my life depended on it. Thanks to rangealone and kastelic for trying to help.