Jump to content


Photo
- - - - -

Changing feature slider options in pagelines causes 404 error


  • Please log in to reply
16 replies to this topic

#1 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 29 January 2012 - 09:22 PM

Hello, Upon upgrading to 2.0 my features slider reverted to the default sample slides (expected). Unfortunately after I try and update the settings in the features section of Pagelines - Special it turns all my admin pages into error 404 pages. The only solution I have found so far is to restore my last back-up and clear my browser cache. I have been able to replicate the problem several times, it doesn't seem to matter which options I change and save on the Pagelines Special page it will return this behavior. Any ideas? or anyone else experiencing this?

#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 29 January 2012 - 09:29 PM

A few people experienced this, as yet we are unable to replicate it. What browser are you using?

#3 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 January 2012 - 05:50 PM

I'm using firefox and chrome. Interestingly, what repairs the problem is to change file permissions of all wordpress folders and sub-folders to 755 via FTP. however, if i try to edit the feature slider again, it will give the 404 error again (until i change file-permissions).

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 30 January 2012 - 05:54 PM

well exactly what files are changing?

#5 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 January 2012 - 06:10 PM

i don't know. i just read somewhere on the web that when you can't access your backend (due to a 404 error), you can try to change the permissions of wp-admin, wp-content and wp-includes and all subfolders to 755. i did that and it gives me access to the backend again. however, everytime i try to change settings for the feature slider, the error comes back and all i can do is set the permissions again. the settings that i make for the feature slider are never saved though.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 30 January 2012 - 06:30 PM

Can you give me a link to the site?

#7 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 January 2012 - 09:46 PM

just sent you a message. i just realized that it is actually sufficient to just clear the browser cache. i'm able to login to the dashboard, but everytime i try to change the feature settings, i get the 404 error until i clear the cache. this is for IE, chrome and FF. i cannot make any changes in the feature settings, however the box settings work fine.

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 30 January 2012 - 10:15 PM

Whatever 'manageWP' is, de-activate it and the problem goes away.

#9 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 30 January 2012 - 10:23 PM

Thanks for your help! ManageWp is a tool that facilitates managing multiple WP blogs. I have deactivated the plugin, but the problem remains. I was able to make adjustments to the feature settings by deactivating the features in the templates sections BUT the settings are ignored by the feature slider (e.g. i set the slider to "no navigation" but the navigation remains").

#10 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 31 January 2012 - 12:50 AM

This happens for some reason in Firefox for me on certain installs but no other browser. Does it happen in Chrome and Safari as well for you?

#11 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 31 January 2012 - 01:46 AM

yes, it happens in all browsers and only with this one install. i'm using a hostnine reseller account. wordpress is up to date (3.3.1) and there is no difference to any other install that i have. here are the plugins that i have installed and activated (deactivating them has not helped): - akismet - limit login attempts - managewp - post types order - wp google fonts

#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 31 January 2012 - 02:28 AM

I was able to save feature options no problems with that plugin deactivated.

#13 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 31 January 2012 - 02:37 AM

thats weird. but are they actually applied in the frontend?

#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 31 January 2012 - 02:43 AM

Yes they are, I changed settings in the post area, and the special settings area with that plugin dosabled, I also tested with all plugins disabled, same result. Only when it was enabled I got the 404.

#15 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 31 January 2012 - 02:49 AM

okay, for some reason this solution doesnt work for me. HOWEVER, i found another solution: i just change the feature settings on the page/post itself. thanks!

#16 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 31 January 2012 - 03:08 AM

Do you need any other assistance?

#17 skyrocket

skyrocket

    Advanced Member

  • Members
  • 35 posts

Posted 31 January 2012 - 05:35 AM

nope! thx catrina & pross