Jump to content


Photo
- - - - -

Put code in a custom section


  • Please log in to reply
5 replies to this topic

#1 krafit

krafit

    Member

  • Members

  • 15 posts
  • LocationGermany - 'Yeah, we've got the Oktoberfest here'
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 29 January 2012 - 02:36 PM

Hej,

I tried to put some code into a Custom Section.
Using the code outside of the section works well - inside the section some parts (links + thumbnails) seem to be broken

I set up a small test-page to show you the difference:
The Custom section is located in the Content-Area. Underneath the whole page I inserted the code again, so you can see, what it's supposed to look like:

Please Login or Register to see this Hidden Content



And here the Code of the Section:

Please Login or Register to see this Hidden Content



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 29 January 2012 - 05:10 PM

Are you trying to put this section into the main content area?

#3 krafit

krafit

    Member

  • Members

  • 15 posts
  • LocationGermany - 'Yeah, we've got the Oktoberfest here'
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 29 January 2012 - 05:17 PM

yes I do

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 29 January 2012 - 05:31 PM

You can try using this CSS hack (to Custom Code > Custom CSS) to move the content up from below the page so that it doesn't lose its formatting:

Please Login or Register to see this Hidden Content



#5 krafit

krafit

    Member

  • Members

  • 15 posts
  • LocationGermany - 'Yeah, we've got the Oktoberfest here'
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 29 January 2012 - 05:48 PM

@catrina - I thought of something like too. But since its some kind of quick and dirty solution I would prefer getting the section working. Could it be possible that the Loop of the page somehow collides with my code? If I'm right with this there might be a fix for that...(?)

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 29 January 2012 - 05:50 PM

Maybe, but I'm not certain. I'm not a php expert but I'll try to take a closer look at it.