• 0
Sign in to follow this  
Followers 0

PLET 1.5 > Sections > pull quote

Question

Posted · Report post

Working my way through video PLET 1.5, I got to the point where I refresh the store after creating "My Sample Section" steps, and it turned off Base Section (pullquote) and created a new section in Sections with the custom name I created. In your case, My Sample Section. I had to then reactivate the Base Section (pullquote) to get that working again. Does this all sound right? I had also changed the variable "define('WP_DEBUG', false);" to be true, in the wp-config file as explained in the video, and did the same with 'PL_DEV' as well. After refreshing my browser, there appeared a dozen or so debug lines of code at the top of the admin area of WP, and the same showed at the top of the website I'm developing. I assume I have been all instructions clearly, and there doesn't seem to be anything wrong with anything before doing this. Have any idea what is going on?

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Posted · Report post

So, I turned off all of the debugging in the wp-config.php file and things went back to normal. But the following below is what was showing up with WP and PL debugging set to 'true': Notice: Undefined variable: smtpsettings in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/cforms/lib_aux.php on line 15 Notice: Undefined index: cforms_showdashboard in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/cforms/cforms.php on line 1583 Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 3587 Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 3587 Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 3467 Notice: Undefined variable: cache_needs_updating in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/s2member/includes/classes/cache.inc.php on line 97 Warning: fopen(/Users/bens_photo/Sites/wp-olsc/wp-content/plugins/pagelines-sections/pagelines-sections.php) [function.fopen]: failed to open stream: No such file or directory in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 4452 Warning: fread() expects parameter 1 to be resource, boolean given in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 4455 Warning: fclose() expects parameter 1 to be resource, boolean given in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 4458 Notice: Undefined index: update in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/cforms/cforms.php(50) : runtime-created function on line 1 Notice: Undefined index: page in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/s2member/includes/classes/admin-notices.inc.php on line 136

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you look at some of the errors, you will be able to figure out the answers Example: [quote]Notice: Undefined variable: smtpsettings in /Users/bens_photo/Sites/wp-olsc/wp-content/plugins/cforms/lib_aux.php on line 15[/quote] smtpsettings: The "smtp" tells me it's something to do with sending mail. /plugins/cforms/ tells me it's a cforms error. Not much you can do about that except alert the plugin author. For: [quote]Warning: fopen(/Users/bens_photo/Sites/wp-olsc/wp-content/plugins/pagelines-sections/pagelines-sections.php) [function.fopen]: failed to open stream: No such file or directory in /Users/bens_photo/Sites/wp-olsc/wp-includes/functions.php on line 4452[/quote] Have you installed the default PageLines Sections plugin from the store? I assume so (it will be active in your WP -> Plugins. Most of these, especially the notices, you can just ignore.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well that helps me interpret them, thanks. I was doing the Pagelines video PLET-1.5 and was following it; that is what caused these problems. But I now think that I don't need to do what that video teaches? It was showing how to do a custom section, so I did, and these were the debugging I messages I was getting. With that said, what would you make of these bugs? I can contact the cforms autor no problem, but regarding the pagelines Warnings?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

WHen you enable debugging you will see all those warnings and errors. If its not affecting your site negatively I wouldn't worry about it too much, just make sure to turn of debugging on any live site.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Wonderful, thanks. It seems like if you have the latest version of PL (and I do) then the video PLET-1.5 is not relevant except for if you want to know how to debug? I mean, it seems like everything that was done in that video has been added to the most current version of PL 2.0. When I created a new pagelines-section I went through this (see thread), and when I created the custom pagelines-section it deactivated the Pullquotes plugin. So I deactivated the custom one, deleted it of of my harddrive, and reinstalled the one that the video instructs to alter. I get the concept of creating a custom section or the need for one, but the PLET-1.5 video disabled the pullquotes plugin. Maybe there's a video tutorial after that one that re-codes the pullquote functionality back into the custom section?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0