Jump to content


Photo

Home button iblogpro5


  • Please log in to reply
33 replies to this topic

#21 ahansson89

ahansson89

    Advocate

  • Members

  • 522 posts
  • Framework Version:DMS
  • Country: Country Flag

Posted 15 January 2012 - 08:02 PM

Come on, personally I do not want to hire anybody to make this minor fix, I already paid you guys around $250 to get this. The reason I bought this in the first place was to make it easy to develope my website, and I do not feel that I get what was promised.. Please prove me wrong!

#22 Danny

Danny

    Is Awesome!

  • Moderators
  • 15084 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 17 January 2012 - 01:21 PM

@ahansson89 Do you have a link to your site? Also to hide text in CSS, use this: text-indent:-9999px;

#23 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 17 January 2012 - 05:12 PM

my link is: http://test.golink.ch

#24 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 17 January 2012 - 07:16 PM

This may help with the home icon:

Add the following to your custom code -> custom CSS (but change the url between the "" to the location of your home icon image):

 .main_nav ul li.menu-item-home a {
	    background: url('http://www.YOURURL.com/YOURIMAGE.png') transparent no-repeat 15px 4px !important;
	    width: 30px;
	}

And then visit Appearance -> Menus and change the "Navigation Label" of your "Home" menu item to:

 

The menu label will show up blank (it's actually a space) but that's ok.

#25 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 17 January 2012 - 07:25 PM

Thank you for the code but I just tried and it does not work!

#26 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 17 January 2012 - 07:32 PM

Checked your site and don't see this in your CSS (which is why it isn't working):

 .main_nav ul li.menu-item-home a {
	    background: url('http://www.YOURURL.com/YOURIMAGE.png') transparent no-repeat 15px 4px !important;
	    width: 30px;
	}

You also have to upload the image and change the image URL listed in the code above to your URL (the full URL including the http://).

#27 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 17 January 2012 - 07:36 PM

I change url and the image I see on the net so just url: http://test.golink.c...-icon-trans.png

#28 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 17 January 2012 - 07:43 PM

Most likely the reason this is not working is because your "home" page is not really your home page. You have the "home" page set to the "Example" menu link.

So if you want this to work, you will need to either apply the effects to the "Example" menu.

If you want "Redox" as your home page, then you will need to change the CSS to that page.

Remove:
 menu-item-home

Add:
 menu-item-143


#29 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 17 January 2012 - 07:52 PM

Thank you thank you it works!! great another question when I pass the mouse over the link the image and how to hide the image remains at the forefront? http://test.golink.ch

#30 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 17 January 2012 - 11:30 PM

You will probably have to make a darkened home image for the hover state.
Something like this:

 .main_nav ul li.menu-item-home:hover a {
	    background: url('OTHER-URL') !important;
	}


#31 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 17 January 2012 - 11:41 PM

it works thank you but the hover does not work! http://test.golink.ch

#32 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 17 January 2012 - 11:52 PM

Did you make a new, darker version of the image for that?

#33 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 18 January 2012 - 12:08 AM

Oh so I have to create a darker image! Ok thank you for the help

#34 isaia

isaia

    Super Member

  • Members
  • 141 posts

Posted 18 January 2012 - 09:03 AM

How to disable the home button to keep it clear?