• 0
Sign in to follow this  
Followers 0

PageLines Framework 2.0.1 upgrade overwrote widget contents!

Question

Posted · Report post

Figuring a 2.0 to 2.0.1 upgrade was not a major update, I ran it and it worked fine. Except one major thing - all the widgets lost their contents. Is this happening with other sites, and is there a fix other than restoring the site to last night's backup and losing today's work? Thanks.

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Posted · Report post

This is the first I've heard of this happening. Did the widget areas in Appearance -> Widgets become totally blank? Are the widgets perhaps in the Inactive Widgets area?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

They are blank. And not in the inactive widgets area. I know - weird. I looked in the database and in wp_options there is content from one of the widgets: a:3:{i:2;a:0:{}i:3;a:3:{s:5:"title";s:0:"";s:4:"text";s:1248:"
";s:6:"filter";b:0;}s:12:"_multiwidget";i:1;} Yet it doesn't show up in admin or on the site. I can pull the content and get it back into a new widget, but I'll be nervous next time I upgrade if I don't know what happened. Appreciate the help...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I just figured out that the widget contents from the Universal Sidebar was showing up in the MoreFoot Middle widget area.... so it moved somehow.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi Chuck, That's pretty strange it should move, is everything else now resolved ?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

STILL A PROBLEM!! Okay, so I just dealt with the previous problem by re-adding the widgets. It was a pain, but I figured it was probably a one-time problem. Today I wanted to update to 2.1.1, so I created and activated the free child theme from the Pagelines store, then updated. The Widgets all moved again. For example, the Text widget in the Universal Sidebar was suddenly in the MoreFoot Middle sidebar, etc. Seeing that using a Child Theme did not help, I re-activated the Pagelines main theme. Know what happened? The widget that was in the Universal Sidebar disappeared, and the others "moved" again to different positions. I like Pagelines, but if I can't update without major problems, it's unusable.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Have you already tried deactivating all active plugins? It would help to do so to see if any of them might be causing issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0