Jump to content


Photo
- - - - -

PageLines Framework 2.0.1 upgrade overwrote widget contents!


  • Please log in to reply
6 replies to this topic

#1 chucklasker

chucklasker

    Newbie

  • Members

  • 6 posts
  • LocationKauai, Hawaii
  • Country: Country Flag

Posted 04 January 2012 - 10:46 PM

Figuring a 2.0 to 2.0.1 upgrade was not a major update, I ran it and it worked fine. Except one major thing - all the widgets lost their contents. Is this happening with other sites, and is there a fix other than restoring the site to last night's backup and losing today's work? Thanks.

#2 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 04 January 2012 - 11:39 PM

This is the first I've heard of this happening. Did the widget areas in Appearance -> Widgets become totally blank? Are the widgets perhaps in the Inactive Widgets area?

#3 chucklasker

chucklasker

    Newbie

  • Members

  • 6 posts
  • LocationKauai, Hawaii
  • Country: Country Flag

Posted 05 January 2012 - 12:24 AM

They are blank. And not in the inactive widgets area. I know - weird. I looked in the database and in wp_options there is content from one of the widgets: a:3:{i:2;a:0:{}i:3;a:3:{s:5:"title";s:0:"";s:4:"text";s:1248:"

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

Please Login or Register to see this Hidden Content

";s:6:"filter";b:0;}s:12:"_multiwidget";i:1;} Yet it doesn't show up in admin or on the site. I can pull the content and get it back into a new widget, but I'll be nervous next time I upgrade if I don't know what happened. Appreciate the help...

#4 chucklasker

chucklasker

    Newbie

  • Members

  • 6 posts
  • LocationKauai, Hawaii
  • Country: Country Flag

Posted 05 January 2012 - 12:27 AM

I just figured out that the widget contents from the Universal Sidebar was showing up in the MoreFoot Middle widget area.... so it moved somehow.

#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 17015 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 05 January 2012 - 09:48 AM

Hi Chuck, That's pretty strange it should move, is everything else now resolved ?

#6 chucklasker

chucklasker

    Newbie

  • Members

  • 6 posts
  • LocationKauai, Hawaii
  • Country: Country Flag

Posted 02 February 2012 - 05:55 AM

STILL A PROBLEM!! Okay, so I just dealt with the previous problem by re-adding the widgets. It was a pain, but I figured it was probably a one-time problem. Today I wanted to update to 2.1.1, so I created and activated the free child theme from the Pagelines store, then updated. The Widgets all moved again. For example, the Text widget in the Universal Sidebar was suddenly in the MoreFoot Middle sidebar, etc. Seeing that using a Child Theme did not help, I re-activated the Pagelines main theme. Know what happened? The widget that was in the Universal Sidebar disappeared, and the others "moved" again to different positions. I like Pagelines, but if I can't update without major problems, it's unusable.

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 03 February 2012 - 03:09 AM

Have you already tried deactivating all active plugins? It would help to do so to see if any of them might be causing issues.