Jump to content


Photo

Menu in IE7 disappears


  • Please log in to reply
3 replies to this topic

#1 hyest

hyest

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 16 December 2011 - 05:35 PM

I'm using ecopro, I have customized it a bit but I didn't add any odd code to it. I also checked a few other sites I built on eco-pro and they all have the same problem with either the menu missing or the menu being in a way different position than other browsers. Here's the example on my main site( http://www.christopherpadilla.com ): Here's the example on another site where the menu is just off to the right and looking odd ( http://www.grrx.org ): Any help would be appreciated, Chris

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 16 December 2011 - 05:54 PM

Less than 3.4% of Internet users have IE7 which is not even supported by Microsoft anymore. Most of those users are in 3rd world countries. I would suggest that yo upgrade your computer and keep the browser updated, too.

#3 hyest

hyest

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 16 December 2011 - 09:05 PM

I'm aware of how worthless IE7 is. I don't use IE7, so I wouldn't conclude that just because I want to fix a crucial part of the website so it works in IE7 that I use it.

If it was something minor it would be ok, but its the navigation menu. Anyways I fixed the problem on my site christopherpadilla.com by using the following code:
 
	#nav{
	  *float:none;  /* Affects IE7 and below */
	}

I'm still stuck on getting the menu to float to the left on the grrx.org website, i got the corners to at least render right by taking out the PIE script i was trying to make work for rounded corners in all browsers. Any help would be appreciated.

Chris

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 17 December 2011 - 05:06 PM

Have you tried deactivating any plugins on grrx.org?