• 0
Sign in to follow this  
Followers 0

How to add a thumbnail image to the excerpt on the homepage?

Question

Posted · Report post

Hi Everyone, I'm not sure if this is already covered, but I want to ask if there is a possible way I can adjust the theme so that the excerpts on the homepage will not only display the set amount of words per post, but also grab the image used in that post. I didn't find a selection that allows me to do so. Currently I have it in blog layout mode (full-width). Let me know if you need me to elaborate. Essentially I want it to look similar to this. http://www.smashingmagazine.com/ Please advise. Thanks! J

Share this post


Link to post
Share on other sites

16 answers to this question

  • 0

Posted · Report post

You'll need to go into the Blog & Posts settings and make sure that thumbnails are enabled in post clips (assuming you have Magazine Mode enabled).

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Does it work in the full width? The layout that we want is based on the full width and not the magazine mode.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Magazine mode allows you to place a number (you specify) of full width posts above the two column magazine posts. You can "trick" the system. Here's how. Make sure you select Magazine mode and let's say you select 10 full width posts. As Catrina said, make sure you have applied the thumbnails to the posts. Then, go to Dashboard > Settings > Reading and set the Blog pages to show at most 10 posts. Your blog page will show 10 full width posts in Magazine mode, complete with thumbnail.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am unable to get this to work. Basically I am looking to use Magazine mode with a nice size image, then a few lines of text. I can not find which files in my child theme to modify to get this to happen. Currently shows like this - http://smal.in/si/CurrentWay_small.png I want it to look like this - http://smal.in/si/DreamState.png any ideas?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Go to Pagelines Settings -> Blog and Posts -> Featured Post Excerpt Mode and select the second option (on top). Although it looks like you may be on PlatformPro rather than Framework, in which case you should disable thumbnails on the blog page in Blog an Posts and then paste this into platformbase/functions.php, assuming you have Base activated: [code] add_action('pagelines_loop_clip_start','custom_thumb'); function custom_thumb(){ the_post_thumbnail(array(200,200)); } [/code]

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Kastelic. you are the freaking MAN! I have been asking this question numerous times for at least a few months, and you are the first person that has given me an answer that worked. LOVE IT. can i press the thanks button numerous times! http://honeytrek.com/ now all i need to figure out is how to shorten the amount of text that shows in these excerpts. any idea?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

You'll need to shorten the excerpts using the filter documented here: http://codex.wordpress.org/Function_Reference/the_excerpt#Control_Excerpt_Length_using_Filters (Added to the functions.php file)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

yeah, i had that code in there, and it was working for 3 months. then stopped working a few days ago. i have since deactivated 100% of my plugins and still not showing the shortened excerpts. i feel my code my be over-rided somehow.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Something is going on in your site. When I viewed it just now, it suddenly burst out with loud music, then went from full-width to a black bar on the right, matching the footer, but also spreading to a thin line at the top. You may not have plugins active but something is doing this. PageLines doesn't actively move the canvas after loading the page. What custom code have you added?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

rangelone, are you visiting http://HoneyTrek.com when you see that issue? might it be an advertisement? or do you see the same exact activity each time. here is the only custom code i have added to functions.php. and none of it is being honored for the last 5 days now, and I am DESPERATE to get this fixed. very desperate. thank you anyone for your help!!!!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I saw it each time, but it's stopped now. It wasn't an ad that moved. It was literally the entire page canvas and on multiple pages. The whole thing shifted about 1cm left, showing a right column in dark grey/black. PageLines provides a format to show featured images (not slides) parallel to the excerpt. Look in Dashboard > PageLines > Settings > Blog And Posts under "Feature Post Excerpt Mode " and select Left, In Excerpt or Right, In Excerpt. This places the thumbnail (featured image) in line with the excerpt. Personally, I sincerely recommend adding your own excerpts to each post, rather than relying upon them to be copied from content. As a teaser, the first or 2nd sentence may simply not be enough. A good teaser works wonders.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm afraid I was giving you instructions for PageLines Framework, not PlatformPro because that was the selected category for the post. Perhaps you should consider upgrading soon as this request is a built in function of Framework. Moving the image in PlatformPro is possible, but it can get a bit tricky. One easy workaround is to simply include an image link (as one would an image in a post, aligned left or right) in the excerpt field in the post, along with selected text.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

hmmm, not sure what you mean by upgrading to PlatformPro, i thought my site was upgraded entirely.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I think you missed the memo. PlatformPro is probably up to date on your site, but we released PageLines Framework (a different product) in early December 2011. A memo went out to all PlatformPro users inviting them to accept a discount if an older purchase, and if newer, you were given a time to obtain the Framework free. PlatformPro, being different from and older than Framework has fewer options.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

i did miss that memo. am i in the category of free upgrade? if so i am all over it. if not, can you help me fix my site with the platform pro setup i have now? thanks!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hi, Has this issue been resolved like your other forum topic ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0