Jump to content


Photo
- - - - -

Is anyone else having issues with 'Post Types Order' Plug-in?


  • Please log in to reply
21 replies to this topic

#1 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 09 December 2011 - 01:04 PM

Hi, I tried 'Post Types Order' plug-in due to recommendation on PlatformPro 1.5.3 admin page but it did not work for me. Now that I am running PageLines 2.0, it is still not working for me. I have tried deleting and downloaded a new copy and installed and activated the new copy but still no go. The 'Re-Order' option appears under everything. ie. Posts, Boxes, Banners, Features, etc., but when I click on say, Re-Order under Posts and see the graphic bars representing each of my blog posts (in the correct order), so I drag and re-order them in the order I like, Save and refresh the page, no change. I have tried with Features too, no go. I just wanted to know if it is just me OR 'Post Types Order' does NOT work with PageLines 2.0. Can someone confirm or deny? Thanks, Paul

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 December 2011 - 05:24 PM

Paul, if it did not work for you before, with 1.5x, then likely there was a plugin conflict that is causing it not to work. I don't think it's really intended for use on regular posts, particularly if you have a large number of them. However if it's not working on the feature slider, boxes, and custom post types, where it's intended to work, then clearly there's a conflict. If the same plugins are present on your site, the conflict would continue irrespective of 2.0. Try turning off your plugins other than Post Types Order and testing it to see if it works without the others. Then reactivate... test... and see which one is conflicting by process of elimination.

#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 09 December 2011 - 05:25 PM

I've tested it on my site and we're using it on PageLines.com with no problems. This indicates that it must be a conflict.

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 09 December 2011 - 05:25 PM

There are several people who have Post Types Order working. Have you already tried deactivating your other plugins?

#5 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 09 December 2011 - 09:01 PM

When I have a conflict like this I usually deactivate all other plugins in batches of 3-5 at a time and then activate them again one by one. This way you can see which one is causing the difficulties. When you found the one which breaks Post Types Order, go to the WP plugin repository and find a replacement. Or contact the plugin developer and ask for a solution.

#6 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 09 December 2011 - 11:36 PM

@rangelone @catrina @yemoonyah, I have disabled other plug-ins and it had no effect. I only have Post Type Order plug-in active. Most recent test was re-ordering boxes. As you can see in the screen shot attached (

Please Login or Register to see this Hidden Content

), Box order has been 'successfully' changed in the plug-in but the reality is no change takes place. Please see

Please Login or Register to see this Hidden Content

and note the boxes does not reflect the change. This site was created from scratch on WordPress 3.2.1 after purchasing PlatformPro 1.5.3 10 days ago so very few posts appear on this site. In fact, it is not a live site yet. Any ideas gurus? Paul

#7 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 10 December 2011 - 12:24 AM

Post types reorder plugin does work. I use it on all of my sites with 1.5 and now 2.0. Since it did not work for you in 1.5, then you definitely have an issue of some sort. Whether it be a plugin conflict, an invalid function, incorrect CSS, something. This plugin works; I have personally used it.

#8 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 10 December 2011 - 12:48 AM

Thanks Simple Mama... now if only someone can help me figure out how to fix it. I have uninstalled and reinstalled this plugin and re-activated. I have even deactivated every other plug-ins. What else can I do to make this plug-in work? Anyone? Pleaseeeee!! : )

#9 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 10 December 2011 - 12:52 AM

You have deactivated ALL plugins, leaving only the post type order plugin enabled? If not, do that, move the boxes, and refresh your page. Another thought, do you have a caching plugin installed? Even if it's disabled, it can cause things to still cache.

#10 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 10 December 2011 - 01:02 AM

Hi, All plug-ins were turned off when I tested. Only plug-ins I use are the ones that was on recommended list in Pagelines so I would assume conflict will be minimal. When that didn't work. While NO plug-ins were active, I uninstalled and reinstalled Post Type Order and activated just that. Still, no go. Odd.

#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 10 December 2011 - 01:31 AM

Okay. In this case, we need to look into whether you have any legacy CSS or old javascripts; or, whether there's some conflict created by settings in wp-config.php. On that last point, please review that file and make sure debug is set to false. I am unsure how many items you intend to re-order, but until you've resolved this, if there are only a few items, I'd suggest considering the alternative method - using the post date to set the order. You do this by changing the time of day when the post appeared.

#12 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 10 December 2011 - 03:13 AM

Hi rangelone - I don't know how to set the 'debug' to false. Also, WordPress is a fresh install with no modifications or special javascript... even if I tried, I will not be able to write a javascript. set I can do is html. :) I might let this one go for now and see if I can indeed use post date/time method or some other like that. Thank you! Paul

#13 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 10 December 2011 - 05:20 PM

I haven't tried debugging to false in the wp-config.php file before but I believe you have to get into that file and change debug=true to debug=false.

#14 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 10 December 2011 - 11:57 PM

Thanks Catrina. As soon as you said to open up a php file, I started to get cold sweat and my hands started to shake sooooo I might leave the debugging until I really have to do it. Thanks! Paul

#15 Jenny

Jenny

    Owned by PageLines

  • Unicorn Store Dev

  • 2917 posts
  • LocationWV
  • Country: Country Flag

Posted 11 December 2011 - 01:57 AM

If you consider this topic closed (or if you'd like to close it for now and start a new topic later), then please accept an answer, thanks!

#16 leografie

leografie

    Member

  • Members

  • 25 posts
  • LocationAmsterdam
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 17 December 2011 - 08:17 PM

I have also just come across this problem. The issue came up with the Boxes, but I can confirm that Posts are also not being re-ordered. I'm running a multisite setup on a development server with the Framework 2.0 and Wordpress 3.3. I've tried disabling all plugins with the exception of Post Types order, also tried variations of Network-wide and site-only activation.

#17 leografie

leografie

    Member

  • Members

  • 25 posts
  • LocationAmsterdam
  • Framework Version:2.3.8
  • Country: Country Flag

Posted 18 December 2011 - 08:37 AM

This looks like it's one of those problems that appears obvious when you find it. After a lot of testing for plugin collisions, I don't think it's anything to do with that (in my case). I tried this both on my multisite setup and a new fresh single site. When initially configuring the plugin in Settings -> Post Types Order I had set the "Minimum level to use plugin" to "Administrator", and had un-checked "Admin Sort" as I had interpreted the description given incorrectly. If you've done the same, try checking "Admin Sort". This corrected the issue for me.

#18 cybersphere

cybersphere

    Super Member

  • Members
  • 201 posts
  • Country: Country Flag

Posted 19 December 2011 - 11:57 AM

I will reinstall the plugin tomorrow and get back to you.

#19 Jackey

Jackey

    Advocate

  • Members


  • 683 posts
  • LocationHelmond
  • Country: Country Flag

Posted 20 December 2011 - 08:16 PM

I still have problems with post type order in combination with the post navigation of Pagelines Themes. Don't know if itis related. But the post navigation is all messed up. Try and navigate backwards through these posts:

Please Login or Register to see this Hidden Content

It is driving me nuts! It is the same with all other plugins disabled.

#20 Jackey

Jackey

    Advocate

  • Members


  • 683 posts
  • LocationHelmond
  • Country: Country Flag

Posted 21 December 2011 - 10:26 AM

Got this response from the plugin maker.

Hello Jackey,
The advanced version contain a different code which correctly return the next/previous post links in all situations. We had that issue before with the free version, the advanced post types orders works fine with Pagelines Themes.

Thank you,
Dan
Support Department


$25 fixed it for me!