Jump to content


Photo
- - - - -

transparent backgrounds in li menu elements on hover


  • Please log in to reply
2 replies to this topic

#1 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 08 December 2011 - 06:28 PM

I've looked at the dozens of topics on this subject but none seem to work (maybe difference of the new framework?).

I cant get my menu backgrounds transparent on hover im using this

Please Login or Register to see this Hidden Content


To no avail, you can see that the red borders work and background color works if I want it say red. If their a secondary element here so its going transparent into the grey or is the transparent statement itself wrong?

Please Login or Register to see this Hidden Content



p.s. dont worry, im not actually using red borders, its just easy to see for testing.

#2 ryanvarley

ryanvarley

    Advanced Member

  • Members

  • 50 posts
  • Country: Country Flag

Posted 08 December 2011 - 06:51 PM

solved: I was right, there's another element here in addition to the link (a) with the grey background color, the li part. ul#menu-main.main-nav li:hover{ background-color:transparent; } This changes it back.

#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 December 2011 - 07:06 PM

I'm glad you were able to resolve this yourself. Largely because it's good to know people are adapting to 2.0, but also because I'm terrible with CSS. ;)