• 0
Sign in to follow this  
Followers 0

transparent backgrounds in li menu elements on hover

Question

Posted · Report post

I've looked at the dozens of topics on this subject but none seem to work (maybe difference of the new framework?). I cant get my menu backgrounds transparent on hover im using this

ul#menu-main.main-nav li.menu-item a:hover{
	background-color:transparent;
	border-left:1px solid red;
	border-right:1px solid red;
	}

To no avail, you can see that the red borders work and background color works if I want it say red. If their a secondary element here so its going transparent into the grey or is the transparent statement itself wrong? http://ryanvarley.co.uk p.s. dont worry, im not actually using red borders, its just easy to see for testing.

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Posted · Report post

solved: I was right, there's another element here in addition to the link (a) with the grey background color, the li part. ul#menu-main.main-nav li:hover{ background-color:transparent; } This changes it back.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I'm glad you were able to resolve this yourself. Largely because it's good to know people are adapting to 2.0, but also because I'm terrible with CSS. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0