Jump to content


Photo

Double Titles with Google+, on EcoPro + WP SEO


  • Please log in to reply
6 replies to this topic

#1 peterb

peterb

    Advanced Member

  • Members

  • 65 posts
  • Country: Country Flag

Posted 07 December 2011 - 07:16 PM

Hi guys,
I'm having a hard time with posting to Google+, as I always get double titles.

Apparently, this is some behavior that is a result of the WP SEO plugin by Yoast.

If anyone is in doubt of what I'm talking about, it's this:

Posted Image

A solution was posted in the WordPress support forum: Double page names, but that did not work for me.

I'm using EcoPro, and of course WP SEO. I don't want to disable the SEO, because I feel it's doing its job for me quite well.

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 December 2011 - 07:49 PM

Have you considered deactivating WP SEO temporarily to see if this resolves the problem? Also, could you try activating Twenty Ten theme with the WP SEO activated and see if the problem still happens. I suspect it will. Please reply when you know.

#3 peterb

peterb

    Advanced Member

  • Members

  • 65 posts
  • Country: Country Flag

Posted 19 December 2011 - 04:02 PM

I solved this thingy. I knew it would disappear if I would disable WP SEO (which I didn't want to do). I also had WP OGP for Facebook activated, which is uneccessary since WP SEO implements it. That caused those duplicates.

#4 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 19 December 2011 - 04:42 PM

You have to correct your settings in WP SEO. There is a section specifically for titles. If you have another SEO plugin installed, you have to delete it is it may be applying changes also. If you have further issues, it is recommended to contact the plugin author(s).

#5 peterb

peterb

    Advanced Member

  • Members

  • 65 posts
  • Country: Country Flag

Posted 22 December 2011 - 03:48 AM

The settings for Titles are, and have always been, as follows.

Posted Image

I'm pretty sure that WP-OGP was the culprit.

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 22 December 2011 - 03:56 AM

You can keep WP-OGP deactivated if it's causing the issue.

#7 peterb

peterb

    Advanced Member

  • Members

  • 65 posts
  • Country: Country Flag

Posted 22 December 2011 - 03:05 PM

That's exactly what I'm doing. But thank you for the confirmation. Also great that this be noted for users who might encounter these problems later on.