Jump to content


Photo
- - - - -

Eco: How to get social icons to show up in footer


This topic has been archived. This means that you cannot reply to this topic.
14 replies to this topic

#1 jweinberger

jweinberger

    Member

  • Members
  • PipPip
  • 16 posts

Posted 25 May 2010 - 10:10 PM

Hi: Any help you can offer is appreciated! According to the theme options page, checking certain social networks will cause their icons to show up in the footer section of pages and on the blog and post pages. But they don't :( I don't want them as a sidebar widget, so the widget is not in the sidebar. How can I accomplish this? is it possible? Thank you!

#2 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 26 May 2010 - 06:05 AM

From your WordPress Admin, navigate to:

Appearance > Editor > Footer (footer.php)

and past this code:

Please Login or Register to see this Hidden Content


above the line:

Please Login or Register to see this Hidden Content


and save. To hide the other ones in the header add this line to your Custom CSS:

Please Login or Register to see this Hidden Content


Thanks, Bryan

#3 jweinberger

jweinberger

    Member

  • Members
  • PipPip
  • 16 posts

Posted 28 May 2010 - 04:12 AM

Thanks! But I"m a bit confused...

I can't find the

Please Login or Register to see this Hidden Content

anywhere in the footer.php

I do find:

Please Login or Register to see this Hidden Content


which looks like it should show the social links but does not.

In either case, it would be much better if they showed up in the header, but they don't - how do I make that happen?

Thanks!

#4 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 28 May 2010 - 09:01 AM

Make absolutely sure you're in footer.php and then Ctrl+F or Cmnd+F and look for:

Please Login or Register to see this Hidden Content


Sorry, I misunderstood you, I thought you wanted to hide the header icons, simply remove the CSS I had you add:

Please Login or Register to see this Hidden Content


Thanks, Bryan

#5 jweinberger

jweinberger

    Member

  • Members
  • PipPip
  • 16 posts

Posted 29 May 2010 - 12:06 AM

no luck finding

Please Login or Register to see this Hidden Content

- sorry. I looked in footer.php - it's not there.

And I never changed the CSS - the header icons didn't show up originally and still don't - can I make them show up?

Thanks!

#6 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 29 May 2010 - 08:20 AM

From your WordPress Admin, you need to navigate to:

EcoPro > Theme Options > Header And Nav

and then scroll down and you'll see where you can put in your various social profile info and then save.

Thanks, Bryan

#7 jweinberger

jweinberger

    Member

  • Members
  • PipPip
  • 16 posts

Posted 31 May 2010 - 09:30 PM

Bryan: I really do appreciate your help, but I think we're not talking about the same theme - I'm not using Pro, I'm using the standard version of Eco (I have not yet determined whether upgrading will be useful for the specific site I'm building). When I go to Theme Options > Pages and Posts, it gives me check boxes to indicate which sharing icons I want in a footer. I checked some of them, but none show up - on any page, post, footer or anywhere I can determine. In Theme Options > Global Options, it lets me put in my twitter name, but I can't see how it uses that. Can you tell me where and how I would see the social sharing icons indicated? or what I might be doing wrong> Thanks! --Jeff

#8 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 01 June 2010 - 05:04 AM

Hmm, I'm not sure how much help I can provide then, as a mod I've familiarized myself with the newest pro templates. My only recommendation would be to upgrade to the newest iBlogPro template. Thanks, Bryan

#9 jweinberger

jweinberger

    Member

  • Members
  • PipPip
  • 16 posts

Posted 01 June 2010 - 05:38 PM

OK, so I hope someone else here can help me then. The theme isn't working as it describes and I am trying to figure out what is wrong and how to fix it. Any help anyone can provide with the above issue (social icons in the footer) is much appreciated. (Bryan: I suggest you ask a colleague who knows my template - Eco, not iBlog - to help. If I can't get this working at least as documented, I'm not sure why I'd consider upgrading. It seems dismissing the question because you don't know the answer yourself is contrary to the forum's purpose also)

#10 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 01 June 2010 - 06:55 PM

Jweinberger, Let me clarify so we can work this out. The free version of the theme has options to show the social icons. When you check the boxes they will show up on the single post page for posts The twitter feed (if active) shows up in the welcome box which you can set in the sidebar options In the pro version these options are expanded so you can place both of these things in more areas. Please let me know if you have any other concerns

#11 triffendesign

triffendesign

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 June 2010 - 02:16 PM

I would like to pick up on this thread. I am also having problems with the social widget appearing in the footer. My

Please Login or Register to see this Hidden Content

shows up with a large white bar across the bottom of the page. To achieve this result I added the widget to the footer (under Appearance --> Widgets) and then put my Facebook URL in under Theme Options to have the Facebook icon show up.

What I would like is for the widget to show up without the white background in the far right column and have it look the same as all the other columns.

I can confirm the lack of a

Please Login or Register to see this Hidden Content

in the footer.php file (I did look using the auto-find).

@Jweinberger: I understand your frustration with the situation. I am almost positive we can figure this out.

#12 triffendesign

triffendesign

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 June 2010 - 08:43 PM

Actually, I wouldn't mind having it look like the Community portion on the bottom of the pagelines web site. Including the icons.

#13 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 07 June 2010 - 04:25 PM

Triffendesign, This is a completely different issue. In your case it looks like some missing markup that is causing this. Make sure all your widgets have titles and that there are no more than 5 widgets in the footer columns area.

#14 triffendesign

triffendesign

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 07 June 2010 - 04:53 PM

There are five widgets in the columns: MiniMeta, Pages, Archives, Pageslines-Social, and Text block

#15 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 08 June 2010 - 04:23 PM

Okay, here is the fix with some CSS. Paste the following code into your custom css area of your theme options: ` #fcolumns_container .socialicons { float:left; background:none; width:20%; border:none; } #fcolumns_container .socialicons .socialeffect { border:none; padding:2px 20px; } #fcolumns_container .socialicons span { text-shadow:0px -1px #666; font-size:16px; display:block; padding-bottom:10px; } `