Jump to content


Photo

How to use the "lightbox" effect in NextGEN Gallery on PlatformPro


  • Please log in to reply
8 replies to this topic

#1 esensio

esensio

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts

Posted 24 November 2011 - 06:35 PM

Hi, I am using NextGEN Gallery on Platform Pro 1.5.3 What I can't figure it out is how to use the lightbox effect instead of any other (thickbox, shutter, etc.) As I understand I must put custom code in the NextGEN Gallery > Options > Effects > Link Code line Anyone can help with that? Alex

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 November 2011 - 07:35 PM

Have you added the code to that plugin to which you refer? Also, have you looked into NextGEN's support forums for any answers? This seems more like a plugin issue than a theme one.

#3 esensio

esensio

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts

Posted 24 November 2011 - 07:44 PM

no, I just can't understand what I must do...what code? .js or another code

#4 esensio

esensio

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts

Posted 24 November 2011 - 08:25 PM

OK, let's start over, it seems my question is not clear enough. I am using WP 3.2.1 with PlatformPro 1.5.3 (Base 1.4.1), NextGEN Gallery 1.8.4 My Settings: NextGEN Gallery > Options > Effects JavaScript Thumbnail effect: Lightbox (Tried also with "Custom" and "none") Link Code line: rel="lightbox[%GALLERY_NAME%]" In my post: [nggallery id=1] When I click on any thumbnail from the list, the image is opened in new page in the same window, so the effect don't trigger. I am not using any other gallery plugins, only the Pre-configured plugins, which PlatformPro refers in PlatformPro Settings > Welcome section What I must do to get the lightbox effect working?

#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 November 2011 - 10:36 PM

I'm unfamiliar with NextGEN, but I'm going to upgrade this to a developer for attention. I'm sorry for the confusion. I was replying to this: "As I understand I must put custom code in the NextGEN Gallery > Options > Effects > Link Code line" Have you contacted NextGEN to ask them about the lightbox option?

#6 esensio

esensio

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts

Posted 24 November 2011 - 11:12 PM

I have not contacted NextGEN, just searched for solution on their website, the Pagelines forum and Wordpress support Forum. Besides I am not sure if lightbox effect is natively supported by NextGEN Gallery and there's a note that only shutter and thickbox effects are supported. I will use thickbox effect for now.

#7 peterb

peterb

    Advanced Member

  • Members

  • 65 posts
  • Country: Country Flag

Posted 08 December 2011 - 04:45 AM

I am dealing with the same thing. Worked for me at first, but when NextGEN (or another plugin) was updated, all went to sh*t (pardon my French). It's really, really annoying, dealing with this problem when you have galleries in old posts that link the visitor almost away from your site, making their experience less than enjoyable.

#8 ksnyde

ksnyde

    Super Member

  • Members
  • 177 posts
  • Framework Version:2.3

Posted 31 December 2011 - 04:46 PM

Not sure if my approach would work for what you're trying to achieve but I've turned the Effects setting in NextGEN to "none" and because I have Fancybox installed I just let it pick doing the lightboxes for me which happened automatically. I still would like a little more control WRT lightbox presentation (aka, want to display picture "title" and "caption/description" different) but I'll look into that over the next few days and this now appears to be a Fancybox configuration issue, not NextGEN. Hope that's helpful. Ken

#9 Jackey

Jackey

    Advocate

  • Members


  • 685 posts
  • LocationHelmond
  • Country: Country Flag

Posted 31 December 2011 - 06:04 PM

@esensio

I use "Highslide 4 Wordpress reloaded" and this works for both Wordpress and NexGEN images and galleries. Good mobile support and easy to translate the frontend. Just install the plugin and as Ken with Fancybox set "Effects" to none in NextGEN.