Jump to content


Photo

Multiple Questions


  • Please log in to reply
5 replies to this topic

#1 marco_terry

marco_terry

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 22 November 2011 - 06:42 PM

Hi All - These are newbie questions - however I have searched for the answers and I cannot find them. Hopefully someone will be able to help. Not I am not very sophisticated when it comes to blogs (big surprise here :-) I started a blog using the free version of this theme. Fairly simple, the main page showed a listing of posts. Likewise, the category pages did the same (here is one example http://www.ccapital.net/blog). I then decided to buy the full version of Whitehouse and apply it to another blog I have (http://factoring.qlfs.com/blog) - however I cannot make it look like my first blog. I have the following issues: 1. The HOME menu item is not there 2. I can't seem to have full posts on the main page and on the category pages/archives. I get full posts on the front page and just title links on the category pages. How do I accomplish this? 3. Ideally, I want full posts on the front page and excerpts every where else. But when I do this I get excerpts on the full post pages as well - meaning I get an excerpt , followed by the full post. The first paragraph gets repeated... Any advice? Best, Marco

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 22 November 2011 - 07:51 PM

1. The menu is created through a Wordpress function and is found in Dashboard > Appearance > Menus. When you say "HOME menu", I presume you mean the menu starting with HOME on the ccapital.net site. If other, please let us know.

2. Are you using the options available at Dashboard > WhitehousePro > Pages And Posts ? This is the bit you're looking for "Full Post Content Placement" and you probably want "Show full content on all blog pages". Don't forget to Save!

3. You can create a static front page and use a plugin called "Special Recent Posts" set to show the full posts, thus bypassing the normal structure http://wordpress.org...-recent-posts/. The repeated first paragraph also stems from incorrect settings in the Pages And Posts settings panel. You want to look at "Post Excerpt Placement"

#3 marco_terry

marco_terry

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 22 November 2011 - 08:27 PM

Hi Rangelone - Thanks for the quick reply. 1. Yes, I mean the HOME menu that many blogs have. When pressed it usually takes you to the blog main directory/page. 2. These are my current Pages and Post Settings: a) Post Thumbnail = Don't Show B) Post Excerpt Placement = Don't Show c) Full Post Content Placement = Show full content on all blog pages Yet, all posts under Categories come as a title only. Full posts on main page and archives. Is it possible to have the posts under Categories be either full posts or summary posts? However, whenever I fiddle with the Post Excerpt Placement i seem to get a repeated first paragraph on posts. Cheers!

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 22 November 2011 - 08:36 PM

Marco. 1. You need to change the menu as you want it to appear in Dashboard > Appearance > Menus to whatever you wish it to be. If necessary, create a new menu (top) called "primary" (save it) then add Custom menu items, linking them where you want them. Otherwise, edit the menu items already there. As for No. 2. I'm going to bump this issue to a developer to take a look at.

#5 marco_terry

marco_terry

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 22 November 2011 - 09:06 PM

Rangleone, Thanks - Menu works like a charm. On #2 - how will I learn of the outcome? Best, Marco

#6 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 22 November 2011 - 11:06 PM

When a moderator marks a post for developer attention, that means a developer will reply to the post, so just check back here. In the meantime there is a way to achieve this. For Excerpt Placement choose "only on blog pages and search" For Full Post Content Placement choose "Show full content on single pages only" Then when you create your post, paste the entirety of the article in the "excerpt" field. You may need to activate the excertp field in Screen Options. Its not an elegant solution but it seems to work.