Jump to content


Photo

Grandchild Menus Don't Work in Safari, Chrome or Internet Explorer


  • Please log in to reply
4 replies to this topic

#1 kaithusmann

kaithusmann

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 19 November 2011 - 03:20 PM

I'm having trouble getting grandchild menus to appear in some browsers. All dropdown menus appear in Firefox: Parent, Child, and Grandparent. Parent and Child menus appear in all browsers I've tested. However, grandchild menus (level three submenus) do not appear in any browser except Mozilla Firefox. Originally I was using the "Automatically add to top level" option in Appearances>Menus. I then recreated a custom navigation bar and added this as the primary menu. No change. Still works in Firefox and still no luck in Safari and Chrome. (Haven't retested in Internet Explorer). I have drop down menu's enabled under the Theme settings. The website is http://southerngreenhomes.ie/sgh I'm really struggling here. I'm going to set up all parent pages as Highlight rather than Feature pages so that I can at least at a submenu sidebar for folks to navigate. But what I'd really like to do is get the grandchild menus working on all pages. How do I ensure that all the dropdown menus including grandchild menus appear in all browsers? Help!! (and thank you in advance..)

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 November 2011 - 05:03 PM

Hm, it's difficult to determine a fix for a specific browser, but I'm trying to search for other topics on this forum addressing the same problem to see if there was any solution found.

#3 kaithusmann

kaithusmann

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 22 November 2011 - 11:12 AM

Hi Catrina! Any joy?? I'm still having the same problem.. Not really sure what to do. I'm wondering if other people are having this problem as well.... I'm considering trying a few different drop down menu plugins like suckerfish. If anyone has any advice I'd really appreciate it. Thank you!!! k8

#4 kaithusmann

kaithusmann

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 22 November 2011 - 11:14 AM

I should mention that this is really important to me to get fixed. So if there is no easy solution I'm happy to pay to have this problem sorted if it requires customization beyond my skill set.

#5 Dominik

Dominik

    Advanced Member

  • Members


  • 47 posts
  • LocationGermany
  • Framework Version:DMS 2.1.5
  • Country: Country Flag

Posted 22 November 2011 - 11:56 AM

try to remove this! ul ul li:hover { display: block; visibility: inherit; /* fixes IE7 'sticky bug' */} or add a # in front of ul ul li:hover