Jump to content


Photo

Feature Slider stopped working on BlogPost page.


  • Please log in to reply
20 replies to this topic

#1 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 15 November 2011 - 12:05 AM

My Feature Sliders stopped working on my BlogPost page after I add the IDs of the pages that I wanted to display each Feature Slide. Feature Sliders were working on all pages before I added Page IDs. I only want the Feature Sliders to appear on their assigned pages, so I added Page IDs to all the Sliders. All the other pages are working except for the PhotoBlog page. Just a little background: I have the PhotoBlog page setup as Post Page in Setting > Reading. And, Features On Blog/Posts Page is turned on in StationPro > Theme Options. Why would Feature Sliders work fine on PhotoBlog page, then stopped working when I added Page IDs ? LINK: http://shaznyc.com/photoblog/ Thanks you.

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 15 November 2011 - 02:42 AM

Is the photoblog page a static page? Was included in the list of page IDs? If not, then the slides won't show there. The reason why it stopped on the photoblog page is that it's being redirected elsewhere when you add page IDs, it must include every single one you want the slider to appear on. It no longer will default to the photoblog.

#3 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 15 November 2011 - 01:18 PM

Thanks Rangelon, As I have mentioned above, I added the "PhotoBlog" page ID to the Feature Slides I wanted to show up there and still none of the Slides are showing. Thanks, SHAZ.

#4 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 15 November 2011 - 03:57 PM

Could you post a screenshot of your settings page, please? Thanks!

#5 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 16 November 2011 - 04:11 AM

Hi Kate, Here is a link to the screen shot of my WordPress Setting > Reading option: http://twitpic.com/7erjiu Thanks, SHAZ.

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 13234 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 November 2011 - 08:41 AM

Hi Shaznyc, I tried to re-create your problem and did, I think this may be a bug. I created two pages, my homepage had an ID of 2 and my blog page had an ID of 24. In features 1 and 2 I added the ID of my Homepage, then with features 3 and 4 I added my blog page ID. The features on my homepage were working but the features on my blog page we not. Can someone else try this before I bump it to a developer please.

#7 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 16 November 2011 - 04:36 PM

Hi Danny, That's exactly what's happening on my end. It may be something to do with the "Stactic" settings of the PhotoBlog page :-( The Feature Sliders are not reading the ID of the PhotoBlog page, I think. Thanks, SHAZ.

#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 16 November 2011 - 06:46 PM

Shaz, I think Kate wanted the settings page for your slider, to see how that's structured, particularly the Page IDs area.

#9 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 16 November 2011 - 11:24 PM

Hi Rangelone and Kate, Here is a link to the screen shot of my Feature Slide Settings with Page IDs option: http://twitpic.com/7f3sub Please note that 37 is the ID for the PhotoBlog page. And that there are no space in between, just a comma. Even though it may look like there's a space after the 37, there is no space. Thanks, SHAZ.

#10 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 16 November 2011 - 11:41 PM

I think the problem is that once you select a page to be your posts page, it ceases to have an id since it is no longer a "page", it just is generated by index.php. (look in the body tag, there are no classes, on a regular page, there are page-id classes)

You can get around this by using CSS to hide features instead, for example:

 .page-id-32 #feature {display:none}
if you want to hide on certain pages
or
 #feature { display:none}
	.page-id-32 #feature {display:block}
if you want to show only on certain pages.

#11 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 16 November 2011 - 11:49 PM

Thank you Kastelic, Where exactly am I to put the set of CSS code you just gave me. I am a newdi to Wordpress. Thanks, SHAZ.

#12 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 17 November 2011 - 03:05 AM

Add the CSS to Custom Code > CSS Rules/Custom CSS in your settings

#13 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 17 November 2011 - 05:21 AM

Thanks Catria, I copy and paste the Custom CSS that Kastelic posted above, and the Feature Slide Box on the PhotoBlog page disappeared altogether. Link to screen shot of Custom CSS is here: http://twitpic.com/7f81tt

#14 Danny

Danny

    Is Awesome!

  • Moderators
  • 13234 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 17 November 2011 - 08:11 AM

Hi Shaznyc, Kastelic is absolutley right, I didn't even think of that. When you turn a page into the blog static page it no longer has a number ID, it only has the ID of blog. I think the only way you're going to get the feature slider to work the way you want it to, is to contact one of the Pagelines Pro, as it will require custom code.

#15 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 17 November 2011 - 10:55 PM

Thanks Danny, I have given up the battle on the Feature Slider :-( Is the Carousel also rendered useless on the Static PhotoBlog page? I can't seems to be able to switch it to Carousel either. Thanks, SHAZ.

#16 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 17 November 2011 - 11:13 PM

The CSS I gave you was an example of how to hide or show items on different pages. You will need to adjust it with whatever page ids or classes are specific to your pages. You can find the page ids or classes in the body tag of any given page. Use Google Chrome to right-click and "inspect" or type ctrl-U to view the source. I don't know what pages you want to hide/show the features which is why I couldn't give you specific code. If you can post which pages you want to hide or show it on we can give you specific code to copy and paste.

#17 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 18 November 2011 - 12:10 AM

Thank you Kastelic, This is how I copied and pasted the CSS Code you gave me into the Custom CSS in Feature Settings :- #feature { display:none} .page-id-24 #feature {display:block} #feature { display:none} .page-id-646 #feature {display:block} #feature { display:none} .page-id-37 #feature {display:block} #feature { display:none} .page-id-32 #feature {display:block} As you can see, I replaced your page ID with my page IDs. I added IDs for - "Home = 24", "About =646", "PhotoBlog = 37", "Gallery = 32". And that doesn't seems to work either.

#18 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 18 November 2011 - 12:44 AM

The
#feature { display:none}

HIDES all features everywhere so you only need it once. The ones that set it to display:block SHOW the specific features.

If you Hide all, then show one, then hide all again, they will all be hidden.

Try this instead:
 
	#feature { display:none}
	
	.page-id-24 #feature {display:block}
	.page-id-646 #feature {display:block}
	.page-id-37 #feature {display:block}
	.page-id-32 #feature {display:block}

OR if you want to be really succinct, you can set multiple rules at once seperated by commas like this:
 
	#feature { display:none}
	
	.page-id-24 #feature
	, .page-id-646 #feature
	, .page-id-37 #feature
	, .page-id-32 #feature
	{
	display:block
	}
This can be nice for when you need to add more in the future.

#19 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 18 November 2011 - 12:46 AM

Also, for pages that don't have an id, like the blog page, search page, or an archive page, look for the other unique classes in the body tag like .archive .category .category-wedding .category-31 and so on. These can be used in place of the .page-id-32 type of classes

#20 shaznyc

shaznyc

    Advanced Member

  • Members
  • 70 posts

Posted 18 November 2011 - 02:41 AM

Thanks Kastelic, So far none of the CSS Codes are working. I have left my sword and my shield at the battle field. I'm thinking my only option now is to duplicate the Feature Slides I want to show on the PhotoBlog page and leave them without IDs. The problem with duplicating is that there is no fast way to do that, except to copy and paste each and every line of texts. Question! If I buy PlatformPro, will I be able to customize my StationPro3 site? I'm feeling limited with the StationPro3 theme and I really need more flexibility? For example:- will I be able to add Feature Slides and Carousel, (or both Feature Slides and Carousel at the same time) to my PhotoBlog page? Thank you, SHAZ.